Epic #55065

Epic #55070: Workpackages

WP: Overall System Performance (Backend and Frontend)

Added by Ingo Schmitt almost 7 years ago. Updated about 3 years ago.

Status:
Closed
Priority:
Should have
Assignee:
-
Category:
Performance
Target version:
-
Start date:
2010-07-02
Due date:
2014-07-09
% Done:

100%

Estimated time:
(Total: 38.00 h)
Sprint Focus:

Description

TYPO3 6.2 LTS will be used in enterprise environments as well as on budget hosting-environments. These systems will have a lot of content or many requests or even both.
In order to provide the necessary technical basis for those use cases, the overall performance of TYPO3 CMS must be in- creased. Also, the main performance of TYPO3 will be reviewed and optimized to get a faster system.


Subtasks

Story #55071: review current caching types and differentiate these typesClosed2014-01-16

Actions
Story #55072: implement compile time cacheClosed2014-01-16

Actions
Story #55073: review autoloader and language cacheClosed2014-01-14

Actions
Task #54990: ClassLoader cache ist too slow, no matter which CF Backend is usedClosed2014-01-14

Actions
Task #54984: "Clear all caches" makes the site unavailable for several secondsClosed2014-01-14

Actions
Story #55074: implement configuration cacheClosed2014-01-16

Actions
Story #55075: review TCA cache and increase performance and scalabilityClosed2014-01-16

Actions
Story #55076: review frontend rendering cache and rootline cacheClosed2012-07-26

Actions
Task #39295: Wrong expires date in cf_cache_pagesectionClosed2012-07-26

Actions
Story #55077: review bootstrap for ajax-calls and streamline processClosed2014-01-16

Actions
Story #55078: Optimize PHP code performance in TYPO3 methodsClosed2013-11-29

Actions
Task #54777: Use PHP native htmlspecialchars_decode()Closed2014-01-06

Actions
Task #54085: Replace all strcmp() calls with ===Closed2013-11-29

Actions
Task #54091: Use === operator instead of strlen() to check for zero length stringsClosed2013-11-29

Actions
Task #54265: Use (int) instead of intval() or (integer)ClosedJo Hasenau2013-12-07

Actions
Task #54560: Replace JavaScriptEncoder with json_encode()Closed2013-12-22

Actions
Task #55198: Replace trimExplode + foreach with explode + trim within foreachClosedJo Hasenau2014-01-21

Actions
Task #54525: Optimize file- and path functions in GeneralUtilityClosed2013-12-20

Actions
Task #55122: Cleanup and optimize methods in ExtensionManagementUtilityClosedMichiel Roos2014-01-18

Actions
Task #54734: Optimize ext_tables and ext_localconf cache filesClosed2014-01-03

Actions
Bug #52949: Speed decrease since 4.5Closed2013-09-19

Actions
Task #53029: Improve performance of the class loader ClosedThomas Maroschik2013-10-22

Actions
Task #53744: Change ClassLoader cache from proxy require files to standard cache backendsClosedThomas Maroschik2013-11-18

Actions
Task #53747: Change TCA cache from php code to serialized arrayClosedThomas Maroschik2013-11-18

Actions
Feature #52642: CF: Implement Simple db, apc & memcached backendClosed2013-10-09

Actions
Bug #53556: classLoader->loadClass calls requireOnce twice per classClosed2013-11-12

Actions
Bug #53918: t3skin calls addIconSprite for each languageClosed2013-11-25

Actions
Bug #53962: Class loader does not cache non existing classesClosed2013-11-25

Actions
Bug #53702: FAL fetches storages twice on every BE requestClosed2013-11-16

Actions
Task #54251: GeneralUtility::array_merge_recursive_overrule has bad performanceClosedMarkus Klein2013-12-06

Actions
Bug #53862: isValidUrl idna converts whole URI instead of domain onlyClosed2013-11-22

Actions
Bug #52125: Saving records takes ages to completeClosed2013-09-19

Actions
Bug #52235: Timeout when copying pages recursively due to cache-clearing overloadClosed2013-09-24

Actions
Bug #53598: Select/Delete fe_sessions twice per requestClosedAlexander Opitz2013-11-13

Actions
Bug #54982: Performance of eID-scripts in TYPO3 6.2ClosedAlexander Opitz2014-01-14

Actions
Bug #55022: PackageManager Cache is invalid if typo3 dir has symlinksClosedAlexander Opitz2014-01-15

Actions
Bug #56307: Findings from Bootstrap/PackageManager/ClassLoader analysesClosedSteffen Ritter2014-02-26

Actions
Bug #56308: ClassLoaderCache superflouousClosed2014-02-26

Actions
Bug #56310: The PackageManager checks every boot if all required packages are activeClosedThomas Maroschik2014-02-26

Actions
Bug #56311: PackageFactory does not need to be initialized on regular requestsClosedThomas Maroschik2014-02-26

Actions
Bug #56312: Dependency Resolver does not need to be initializedClosedBenni Mack2014-02-26

Actions
Bug #56313: Cache Identifiers shorten the MD5 hashClosed2014-02-26

Actions
Bug #56314: setCacheHashOptions from Bootstrap not relevant for EIDClosedBenni Mack2014-02-26

Actions
Bug #56315: Optimize TimeTracking init in eID CaseRejected2014-02-26

Actions
Bug #56316: inline BEUserAuth::getCookieNameClosedThomas Maroschik2014-02-26

Actions
Bug #56317: Cache Local and Default Configuration to prevent duplicate File AccessRejected2014-02-26

Actions
Bug #56318: Check wether the ConfigurationManager can be omitted/reduced for the purpose of what the Boostrap really needs from thatClosed2014-02-26

Actions
Bug #56319: Merge Cache/Cache and CacheFactory into CacheManagerClosed2014-02-26

Actions
Bug #56320: Check emptying the Flow Classes as far as possibleRejected2014-02-26

Actions
Bug #56322: GetAliasesForClass not usedClosed2014-02-26

Actions
Bug #56323: cache_classes should cluster by Package instead of ClassClosed2014-02-26

Actions
Bug #56324: Class Loader should not try to runtime resolve class-pathesClosed2014-02-26

Actions
Bug #56325: Move "finalClassNameCache" from GeneralUtility to ClassLoaderClosed2014-02-26

Actions
Bug #56326: Evaluate and Merge ClassAliasMap into Classloader classRejected2014-02-26

Actions
Bug #56328: Extract complex "class loader cache building" code into ClassLoadingInformationFactoryClosed2014-02-26

Actions
Bug #56330: Add all classes which are needed anyhow within the minimal Bootstrap to the require list in system environment builderRejected2014-02-26

Actions
Bug #56331: Evaluate if we can profit from concatenate all baseRequiredClasses into one fileClosed2014-02-26

Actions
Bug #56333: MicroOptimize ClassLoaderClosed2014-02-26

Actions
Bug #56334: Prevent inclusion of LogLevel due to ConfigDefault referralRejected2014-02-26

Actions
Bug #56335: Prevent Inclusion of ResourceStorage from BootstrapClosedThomas Maroschik2014-02-26

Actions
Bug #56336: Prevent Inclusion of MediaWizardProvider* in Base BootstrapClosed2014-02-26

Actions
Bug #56337: Remove manual array calculation in Locales and put the arrays to the class directlyClosed2014-02-26

Actions
Bug #56340: Remove the VariableFrontend from requiredBaseClassesClosed2014-02-26

Actions
Task #56341: Evaluate if it is really reasonable to have TYPO3\CMS\Core\Compatibility\LoadedExtensionsArrayClosedSteffen Ritter2014-02-26

Actions
Task #56538: Cache the $GLOBALS['TYPO3_LOADED_EXT'] as an arrayClosedThomas Maroschik2014-03-04

Actions
Bug #56933: Cached class loader misses are not considered on retrievalClosedThomas Maroschik2014-03-15

Actions
Task #56934: Move information in Package classes into composer filesClosedThomas Maroschik2014-03-15

Actions
Story #57862: Add possibility to make all TCA additions cachedClosed2014-04-12

Actions
Task #57863: Introduce a signal in ExtensionManagementUtility::loadBaseTcaClosed2014-04-12

Actions
Task #57881: Make category TCA changes cacheableClosed2014-04-13

Actions
Task #57942: Provide API to add cached TCA changesClosed2014-04-15

Actions
Bug #23069: Bottleneck in t3lib_tcemainClosed2010-07-02

Actions
Task #55179: Optimize SQL PerformanceClosed2011-06-11

Actions
Bug #55180: Increase Determination of siteroot pageClosedIngo Schmitt2014-01-20

Actions
Bug #55181: Speedup domain redirection lookupClosedIngo Schmitt2014-01-20

Actions
Bug #55182: Speedup selection of storageClosedIngo Schmitt2014-01-20

Actions
Bug #55184: Filling the entries from sys_registry does not use an indexClosedIngo Schmitt2014-01-20

Actions
Feature #27372: Execute native prepared queries in t3lib_DBClosedXavier Perseguers2011-06-11

Actions
Bug #24960: Rewrite t3lib_loadModules::getRelativePath()Rejected2011-02-04

Actions
Task #55578: DocumentationClosed2014-02-02

Actions
Epic #55656: Optimize overall Extbase performanceClosed2013-06-082014-07-09

Actions
Task #55654: Extbase: Optimize ClassInfoFactory with the ClassInfoCacheClosedMarc Bastian Heinrichs2014-02-04

Actions
Story #55168: Optimize Extbase generic persistenceClosedFelix Oertel2013-11-112014-07-09

Actions
Task #55167: Extbase: avoid parseQuery() / buildQuery() to be called multiple timesClosedFelix Oertel2014-03-202014-03-20

Actions
Task #55661: Add functional tests for extbase persistenceClosedFelix Oertel2014-03-202014-03-20

Actions
Task #57173: Use of cf_extbase_typo3dbbackend_queries results in fatalClosedXavier Perseguers2014-03-22

Actions
Task #57130: Extbase Queries with NULL comparison don't work anymoreClosed2014-03-21

Actions
Task #57104: Regression: Query building fails for LazyObjectStorageClosed2014-03-20

Actions
Task #57263: Typo3DbQueryParser does not handle LowerCaseInterface correctlyClosedFelix Oertel2014-03-25

Actions
Task #57338: Make Typo3DbQueryParser SingletonClosed2014-03-26

Actions
Task #55169: Extbase: fetch child objects in one queryRejectedFelix Oertel2014-07-22

Actions
Feature #60460: Refactor lazyLoading handling in extbaseClosedFelix Oertel2014-07-22

Actions
Task #53514: Extbase: DataMapper causes redundant queriesClosedNico de Haen2013-11-11

Actions
Task #55360: Extbase: use preparedStatement in generic persistenceClosedFelix Oertel2014-03-19

Actions
Task #57067: Follow-Up re-use preparedStatement objectRejectedFelix Oertel2014-03-19

Actions
Task #57254: Fix usage of own prepared statement object in $query->statementClosed2014-03-24

Actions
Task #56979: Add setting for DataMapper to enable preparedStatementsClosed2014-03-17

Actions
Task #59917: User Repositories in internal persistence logicRejectedFelix Oertel2014-06-272014-07-09

Actions
Story #54567: Extbase: overall performance of backend modulesClosedFelix Oertel2013-12-22

Actions
Task #54571: Extbase: Avoid TS parsing in BE if not necessaryClosedFelix Oertel2013-12-22

Actions
Task #55653: belog: cache the beusers usernameClosed2014-02-04

Actions
Feature #48960: Extbase: Backport lazy dependency injectionRejectedMarc Bastian Heinrichs2013-06-08

Actions
Story #55079: review Extbase caching for frontend and backendClosed2014-01-02

Actions
Task #55044: Make Extbase use cache group "pages"ClosedBenni Mack2014-01-16

Actions
Task #54701: Cache global TypoScript template in backendClosedFelix Oertel2014-01-02

Actions
Task #57594: Optimize ReflectionService Cache handlingClosedMarc Bastian Heinrichs2017-05-31

Actions
Feature #81389: Injected ReflectionService without call to initialize/shutdownClosed2017-05-31

Actions
Task #54605: Inject annotations should not be used by core (~5% performance)ClosedMarc Bastian Heinrichs2013-12-26

Actions
Task #56108: Cleanup \TYPO3\CMS\Recordlist\RecordList\DatabaseRecordList and friendsClosed2014-02-19

Actions
Task #56109: Cleanup \TYPO3\CMS\Lang\LanguageServiceClosed2014-02-19

Actions
Task #56110: IconUtility::getSpriteIcon() needs a cacheClosed2014-02-19

Actions
Bug #58357: Superfluous SQL queries on copying recordsClosedOliver Hader2014-04-30

Actions
Bug #59587: Performance killer: APC cache backend, wrong assignment of cache tagsClosedAlexander Opitz2014-06-15

Actions

Related issues

Related to TYPO3 Core - Feature #17085: HTTP GET 'If-Modified-Since' ignoredClosed2007-03-06

Actions
Related to TYPO3 Core - Bug #56354: Speed up updating the extension listClosedBenni Mack2014-02-26

Actions
#1

Updated by Ingo Schmitt almost 7 years ago

  • Estimated time set to 400.00 h
  • Parent task set to #55070
#2

Updated by Mathias Schreiber about 5 years ago

  • Target version deleted (6.2.0)
#3

Updated by Benni Mack about 3 years ago

  • Status changed from New to Closed

Also available in: Atom PDF