Bug #55184

Epic #55070: Workpackages

Epic #55065: WP: Overall System Performance (Backend and Frontend)

Task #55179: Optimize SQL Performance

Filling the entries from sys_registry does not use an index

Added by Ingo Schmitt over 5 years ago. Updated over 5 years ago.

Status:
Closed
Priority:
Should have
Assignee:
Category:
Performance
Target version:
Start date:
2014-01-20
Due date:
% Done:

0%

Estimated time:
2.00 h
TYPO3 Version:
6.2
PHP Version:
Tags:
Complexity:
Is Regression:
No
Sprint Focus:

Description

While filling the cache by Registry->loadEntriesByNamespace the Entries of the Database are fetched.

Count: 44 Time=0.00s (0s) Lock=0.00s (0s) Rows=111.7 (4915), webuser[webuser]@localhost
SELECT * FROM sys_registry WHERE entry_namespace = 'S'

Since the is no index on entry_namespace this query is not cached and executed slower.

Solution: Add index on entry_namespace

History

#1 Updated by Ingo Schmitt over 5 years ago

  • Estimated time changed from 0.50 h to 2.00 h

#2 Updated by Ingo Schmitt over 5 years ago

SQL Statement is no more present in current master. So close

#3 Updated by Ingo Schmitt over 5 years ago

  • Status changed from New to Closed

Also available in: Atom PDF