Bug #55662

PHP Warning preg_replace in current master

Added by Jan Kiesewetter over 5 years ago. Updated about 1 year ago.

Status:
Closed
Priority:
Should have
Assignee:
-
Category:
Backend API
Target version:
-
Start date:
2014-02-04
Due date:
% Done:

100%

TYPO3 Version:
6.2
PHP Version:
5.3
Tags:
Complexity:
easy
Is Regression:
No
Sprint Focus:

Description

I get a PHP warning in the current master:
PHP Warning
PHP Warning: preg_replace(): Unknown modifier 'l' in typo3_src-git/typo3/sysext/core/Classes/Utility/ExtensionManagementUtility.php line 634

Seems to be related to commit aa37842bd4468c9313bd98c97d6d2d76ad44e6b5


Related issues

Related to TYPO3 Core - Task #55122: Cleanup and optimize methods in ExtensionManagementUtility Closed 2014-01-18

Associated revisions

Revision eaad1327 (diff)
Added by Philipp Bergsmann over 5 years ago

[BUGFIX] PHP warning due to missing preg_quote

Fixing a missing preg_quote() call in ExtensionManagementUtility,
which causes a PHP warning and a failing preg_match().

Resolves: #55662
Releases: 6.2
Change-Id: Iaf1e21546741ae282016f433bf83f7e5663e3c7b
Reviewed-on: https://review.typo3.org/29145
Reviewed-by: Markus Klein
Tested-by: Markus Klein
Reviewed-by: Pascal Dürsteler
Tested-by: Pascal Dürsteler
Reviewed-by: Stefan Neufeind
Tested-by: Stefan Neufeind

History

#1 Updated by Jan Kiesewetter over 5 years ago

Sorry, wrong PHP version.

It's 5.3

#2 Updated by Gerrit Code Review over 5 years ago

  • Status changed from New to Under Review

Patch set 1 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/29145

#3 Updated by Markus Klein over 5 years ago

  • Category set to Backend API
  • PHP Version changed from 5.2 to 5.3
  • Complexity set to easy

#4 Updated by Philipp Bergsmann over 5 years ago

For example one fieldReplacePattern which doesn't work for me: /(?:^|,)\s*\bLLL:EXT:lang/locallang_tca.xlf:sys_category.tabs.category\b[^,$]*/

#5 Updated by Gerrit Code Review over 5 years ago

Patch set 2 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/29145

#6 Updated by Philipp Bergsmann over 5 years ago

  • Status changed from Under Review to Resolved
  • % Done changed from 0 to 100

#7 Updated by Benni Mack about 1 year ago

  • Status changed from Resolved to Closed

Also available in: Atom PDF