Project

General

Profile

Actions

Bug #55989

closed

Debug "Column 'cookie' cannot be null"

Added by Thomas Skierlo over 10 years ago. Updated over 5 years ago.

Status:
Closed
Priority:
Should have
Assignee:
-
Category:
Indexed Search
Target version:
-
Start date:
2014-02-14
Due date:
% Done:

100%

Estimated time:
TYPO3 Version:
6.2
PHP Version:
5.3
Tags:
Complexity:
easy
Is Regression:
Yes
Sprint Focus:

Description

Function writeSearchStat of SearchFormController.php triggers a debug message in FE, because $this->fe_user->id resolves to NULL and cookie is a non-null column.
(possibly the same will happen in SearchController.php)

$insertFields = array(
                        'searchstring' => $this->piVars['sword'],
                        'searchoptions' => serialize(array($this->piVars, $sWArr, $pt)),
                        'feuser_id' => (int)$this->fe_user->user['uid'],
                        // fe_user id, integer
                        'cookie' => $this->fe_user->id,
                        // cookie as set or retrieve. If people has cookies disabled this will vary all the time...
                        'IP' => GeneralUtility::getIndpEnv('REMOTE_ADDR'),
                        // Remote IP address
                        'hits' => (int)$count,
                        // Number of hits on the search.
                        'tstamp' => $GLOBALS['EXEC_TIME']
                );

This seems to have started after 6.2.0beta3


Related issues 1 (0 open1 closed)

Related to TYPO3 Core - Bug #53662: DatabaseConnection INSERTquery does not allow NULL valuesClosed2013-11-15

Actions
Actions #1

Updated by Markus Klein over 10 years ago

  • Status changed from New to Accepted

This is due to the patch that allowed to insert NULL values into DB.

From time to time some place popup where the insert was not constructed properly, like here.

Can you push a patch?

Actions #2

Updated by Markus Klein over 10 years ago

  • Complexity set to easy
  • Is Regression changed from No to Yes

Target versions are all 6.x

Actions #3

Updated by Gerrit Code Review about 10 years ago

  • Status changed from Accepted to Under Review

Patch set 1 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/28281

Actions #4

Updated by Georg Ringer about 10 years ago

  • Status changed from Under Review to Resolved
  • % Done changed from 0 to 100
Actions #5

Updated by Benni Mack over 5 years ago

  • Status changed from Resolved to Closed
Actions

Also available in: Atom PDF