Bug #56291

Fatal error: Call to a member function query() on a non-object

Added by Steffen Müller over 8 years ago. Updated over 7 years ago.

Status:
Closed
Priority:
Should have
Assignee:
-
Category:
Database API (Doctrine DBAL)
Target version:
Start date:
2014-02-25
Due date:
% Done:

0%

Estimated time:
TYPO3 Version:
6.2
PHP Version:
Tags:
Complexity:
Is Regression:
No
Sprint Focus:

Description

When activating EXT:dbal in EM, I run into:

Fatal error: Call to a member function query() on a non-object in /var/www/typo3/typo3_src-master/typo3/sysext/core/Classes/Database/DatabaseConnection.php on line 457

It breaks the whole installation, until I manually remove dbal from LocalConfiguration and PackageStates.

master @4da4dba52009760005095a5013245d5d169ce9a5


Related issues

Is duplicate of TYPO3 Core - Bug #51458: Fatal error: function query() DatabaseConnection.php on line 986Closed2013-08-28

Actions
#1

Updated by Stefan Froemken over 8 years ago

Hello Steffen,

I know this problem, too. Here is a workaround:

Edit LocalConfiguration.php and change following line:

'dbal' => 'a:2:{s:10:"sql_query.";a:1:{s:11:"passthrough";s:1:"1";}s:13:"Compatibility";s:0:"";}',

to

'dbal' => 'a:2:{s:10:"sql_query.";a:1:{s:11:"passthrough";s:1:"0";}s:13:"Compatibility";s:0:"";}',

Clear cached LocalConfiguration in typo3temp/Cache/Code/ and you're done.

Stefan

#2

Updated by Mathias Schreiber over 7 years ago

  • Status changed from New to Closed

will continue in #51458

Also available in: Atom PDF