Bug #56539

Update/Change file-hash when file is replaced with a new one with the filelist

Added by Benjamin no-lastname-given over 5 years ago. Updated over 3 years ago.

Status:
Closed
Priority:
-- undefined --
Assignee:
-
Category:
File Abstraction Layer (FAL)
Target version:
Start date:
2014-03-04
Due date:
% Done:

0%

TYPO3 Version:
6.1
PHP Version:
5.4
Tags:
Complexity:
Is Regression:
No
Sprint Focus:

Description

If you have for example a resized image on your webpage:

<img src="/typo3temp/_processed_/csm_filename_ccc_cc_de_ff24b110eb.jpg" />

And you do overwrite this image with a new image (same size and name) in the filelist,

then the filehash at the end should change, so that the browser loads the new file and does not show the old, cached version.


Related issues

Related to TYPO3 Core - Bug #44645: Preview images don't get a new filename after overwriting with updated file Closed 2013-01-18

History

#1 Updated by Benjamin no-lastname-given over 5 years ago

  • Target version set to 6.2.0

I think to implement this the file hashing logic must be changed or extended.
The hash function may need to include the first xxx bytes of the file itself or some filesystem info like the changed/created date.
Is the hash function in TYPO3 6.2 the same as in 6.1?
Maybe we can get this change into 6.2 before release?

#2 Updated by Mathias Schreiber over 4 years ago

  • Category set to File Abstraction Layer (FAL)
  • Sprint Focus set to On Location Sprint

Unsure if this has not already been tackled

#3 Updated by Mathias Schreiber over 4 years ago

  • Status changed from New to Closed

duplicate of #44645. Will continue there

#4 Updated by Anja Leichsenring over 3 years ago

  • Sprint Focus deleted (On Location Sprint)

Also available in: Atom PDF