Bug #56750

delete method of FileInterface results in an Uncaught TYPO3 Exception.

Added by Stig Nørgaard Færch over 7 years ago. Updated over 5 years ago.

Status:
Closed
Priority:
Should have
Assignee:
-
Category:
File Abstraction Layer (FAL)
Target version:
-
Start date:
2014-03-11
Due date:
% Done:

0%

Estimated time:
TYPO3 Version:
6.2
PHP Version:
5.4
Tags:
Complexity:
Is Regression:
No
Sprint Focus:

Description

When I execute the delete method:
$storage->getFile($identifier)->delete();

I get this Uncaught TYPO3 Exception:
#1283790586: There is no entry in the $TCA array for the table "sys_file_processedfile". This means that the function enableFields() is called with an invalid table name as argument. (More information)

If I omit the delete() method, and just execute getFile(), no errors occur.

Its correct that there seems to be not TCA entry for sys_file_processedfile - am I supposed to defined it myself? :-)

tested on TYPO3 6.2beta6

#1

Updated by Stig Nørgaard Færch over 7 years ago

I can add that this worked on TYPO3 6.1.7, but failed when upgraded to 6.2beta6.

#2

Updated by Hendrik Reimers almost 7 years ago

Have the same problem on 6.2.4 ...is there a solution available?

#3

Updated by Riccardo De Contardi over 5 years ago

  • Category set to File Abstraction Layer (FAL)
  • Status changed from New to Needs Feedback

Hi, could you tell me if this error still occurs on 6.2.17 or the latest master (8.0-dev)?

Thank you

#4

Updated by Riccardo De Contardi over 5 years ago

  • Status changed from Needs Feedback to Closed

No feedback within the last 90 days => closing this issue.

If you think that this is the wrong decision or experience this issue again, then please write to the mailing list typo3.teams.bugs with issue number and an explanation or open a new ticket and add a relation to this ticket number.

Thank you

Also available in: Atom PDF