Project

General

Profile

Actions

Bug #56823

closed

Extensionmanager does not show error messages on update failure

Added by Gautam K. over 10 years ago. Updated over 5 years ago.

Status:
Closed
Priority:
Should have
Assignee:
-
Category:
Extension Manager
Target version:
Start date:
2014-03-12
Due date:
% Done:

100%

Estimated time:
TYPO3 Version:
6.1
PHP Version:
5.3
Tags:
Complexity:
Is Regression:
No
Sprint Focus:

Description

When updating extensions through the new extension manager (which is, in general, very slow), I get a page with an opaque overlay.

Trigger the bug:
Try to update an extension that does not fulfill a dependency, e.g. that depends on a lower TYPO3 CMS version.
The EM will return an exception, but this exception is now caught and does not show up in the EM.
Therefore the spinning icon keeps running.

Steps to reproduce:
1. Go to extension manager, 'Manage Extensions' page.
2. Click the update icon next to an extension (e.g. direct_mail, tt_news, div2007, ...).
3. Click 'Yes' on the confirmation prompt.
4. Now you may wait forever: nothing happens. No error, nothing. When refreshing the ext. manager, the extension was not updated.

Files

TYPO3_Exception.html (11.6 KB) TYPO3_Exception.html Gautam K., 2014-03-13 16:34

Related issues 1 (0 open1 closed)

Related to TYPO3 Core - Bug #57797: Extensionmanager does not show error messages on update failureClosed2014-03-12

Actions
Actions #1

Updated by Gautam K. over 10 years ago

This does, however, not occur with all extensions. For example, realurl, tt_address, nagios, powermail, etc. can be updated without this occurring.

Actions #2

Updated by Markus Klein over 10 years ago

Can you check if one of the AJAX requests returns an error?

Actions #3

Updated by Gautam K. over 10 years ago

I looked into it. Apparently, the ajax request to /typo3/mod.php?M=tools_ExtensionmanagerExtensionmanager&tx_extensionmanager_tools_extensionmanagerextensionmanager[extension]=div2007&tx_extensionmanager_tools_extensionmanagerextensionmanager[format]=json&tx_extensionmanager_tools_extensionmanagerextensionmanager[action]=updateExtension&tx_extensionmanager_tools_extensionmanagerextensionmanager[controller]=Download throws a 500 Internal Server Error and returns an exception about my PHP version being too high (I'm using PHP 5.5.3).

PHP 5.5.x is supported by TYPO3 6.1.x, as I read from the downloads page.

Uncaught TYPO3 Exception
Your PHP version is higher than allowed. You can use PHP versions 5.2.0 - 5.4.99

TYPO3\CMS\Extensionmanager\Exception\ExtensionManagerException thrown in file
/path/to/typo3/sysext/extensionmanager/Classes/Utility/DependencyUtility.php in line 222.
Actions #4

Updated by Markus Klein over 10 years ago

  • Status changed from New to Needs Feedback

Ok I guess it shouldn't be a 500 error.
This failure is caused by some extension. check the extensions and their requirements in the ext_emconf.php file.

Actions #5

Updated by Gautam K. over 10 years ago

As a test, I've updated div2007 from 0.11.0 to 1.1.4. The former has a PHP dependency 5.2.0-5.3.99. The latter to 5.4.99 (matches the error). I can, however, update extensions by uploading a t3x file, without any errors occurring (no dependency warnings either).

Shouldn't I get a message stating that my environment doesn't match the dependencies (with an ignore button), in stead of an exception?

Actions #6

Updated by Markus Klein about 10 years ago

  • Status changed from Needs Feedback to Accepted
Actions #7

Updated by Philipp Gampe about 10 years ago

  • Subject changed from Extensionmanager randomly hangs when updating extension to Extensionmanager does not show error messages on update failure
Actions #8

Updated by Gerrit Code Review about 10 years ago

  • Status changed from Accepted to Under Review

Patch set 1 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/28738

Actions #9

Updated by Gerrit Code Review about 10 years ago

Patch set 2 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/28738

Actions #10

Updated by Gerrit Code Review about 10 years ago

Patch set 3 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/28738

Actions #11

Updated by Gerrit Code Review about 10 years ago

Patch set 4 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/28738

Actions #12

Updated by Gerrit Code Review about 10 years ago

Patch set 1 for branch TYPO3_6-1 of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/29735

Actions #13

Updated by Philipp Gampe about 10 years ago

  • Status changed from Under Review to Resolved
  • % Done changed from 0 to 100
Actions #14

Updated by Benni Mack over 5 years ago

  • Status changed from Resolved to Closed
Actions

Also available in: Atom PDF