Bug #57064

New option clearCache.system does not show up

Added by Francois Suter over 5 years ago. Updated about 2 years ago.

Status:
Closed
Priority:
Must have
Category:
Backend User Interface
Target version:
Start date:
2014-03-19
Due date:
% Done:

100%

TYPO3 Version:
6.2
PHP Version:
5.3
Tags:
Complexity:
easy
Is Regression:
No
Sprint Focus:

Description

With #54991 a new system cache was introduced, along with a new TSconfig property, called options.clearCache.system. However setting this option to true does not work if the user does not also have either options.clearCache.pages or options.clearCache.all set to true too.

This is because the \TYPO3\CMS\Backend\Toolbar\ClearCacheToolbarItem does not add the "system" options to the list of values to check for granting access.


Related issues

Related to TYPO3 Core - Story #54991: Improve caching framework by introducing groups Closed 2014-01-15
Related to TYPO3 Core - Bug #57703: ClearCacheToolbarItem must implement ClearCacheActionsHookInterface Closed 2014-04-07

Associated revisions

Revision 3e651c38 (diff)
Added by Francois Suter over 5 years ago

[BUGFIX] clearCache.system does not show up

New TSconfig option clearCache.system does not work as expected
because class \TYPO3\CMS\Backend\Toolbar\ClearCacheToolbarItem
wrongly checks access to that option. Thus if only clearCache.system
is set the clear cache menu does not show up at all.

Resolves: #57064
Releases: 6.2
Change-Id: I51c9605c830a9099f21d254ae86d8d6cc430b02a
Reviewed-on: https://review.typo3.org/28518
Reviewed-by: Markus Klein
Tested-by: Markus Klein
Reviewed-by: Wouter Wolters
Reviewed-by: Kay Strobach
Tested-by: Kay Strobach
Reviewed-by: Francois Suter
Tested-by: Francois Suter

History

#1 Updated by Gerrit Code Review over 5 years ago

  • Status changed from Accepted to Under Review

Patch set 1 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/28518

#2 Updated by Francois Suter over 5 years ago

Steps to reproduce:

  • take an non-admin user and options.clearCache.system = 1 to its TSconfig, taking care that there are no other "clearCache" options set
  • switch to that user => the clear cache menu does not show up
  • apply the patch => the menu shows up

#3 Updated by Gerrit Code Review over 5 years ago

Patch set 2 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/28518

#4 Updated by Gerrit Code Review over 5 years ago

Patch set 3 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/28518

#5 Updated by Gerrit Code Review over 5 years ago

Patch set 4 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/28518

#6 Updated by Francois Suter over 5 years ago

  • Status changed from Under Review to Resolved
  • % Done changed from 0 to 100

#7 Updated by Riccardo De Contardi about 2 years ago

  • Status changed from Resolved to Closed

Also available in: Atom PDF