Bug #57261

Fix warning during extension installation

Added by Helmut Hummel about 7 years ago. Updated over 3 years ago.

Status:
Closed
Priority:
Should have
Assignee:
-
Category:
Extension Manager
Target version:
Start date:
2014-03-25
Due date:
% Done:

100%

Estimated time:
TYPO3 Version:
6.2
PHP Version:
Tags:
Complexity:
Is Regression:
No
Sprint Focus:

Description

During unpacking of an extension in the installation
process it can happen that the extension data
contains folders in the file list.

These folders need to be removed from the list
in order to avoid warnings when trying to write
directories as files.

Also remove duplicates form folders before
creating them.

Besides fix some comparisons to strict comparisons
on the go.


Related issues

Is duplicate of TYPO3 Core - Bug #57257: EM: Extracting t3x tries to do a "writeFile" on directoriesClosedErnesto Baschny2014-03-24

Actions

Also available in: Atom PDF