Bug #57271

Task #57031: Cleanup Extbase persistance classes

Can't inherit abstract function TYPO3\CMS\Extbase\Persistence\ObjectMonitoringInterface::_memorizeCleanState()

Added by Claus Harup over 5 years ago. Updated about 2 years ago.

Status:
Closed
Priority:
Must have
Assignee:
Category:
Extbase
Target version:
Start date:
2014-03-25
Due date:
% Done:

100%

TYPO3 Version:
6.2
PHP Version:
Tags:
Complexity:
Is Regression:
Yes
Sprint Focus:

Description

When changing from TYPO3 6.2rc1 to TYPO3 6.2rc2

Adding an Extbase plugin like this:

30 = USER
30{
    userFunc = TYPO3\CMS\Extbase\Core\Bootstrap->run
    extensionName = TcBase
    vendorName = TYPOCONSULT
    controller = Page
    pluginName = Base
    switchableControllerActions{
        Page{
            1 = show
        }
    }
}

gives me Can't inherit abstract function TYPO3\CMS\Extbase\Persistence\ObjectMonitoringInterface::_memorizeCleanState()

It worked like a charm in TYPO3 6.2rc1

Any clues?

Associated revisions

Revision b036a0d4 (diff)
Added by Markus Klein over 5 years ago

[BUGFIX] Extbase: Methods are inherited twice

Change #57031 introduced two methods in DomainObjectInterface,
which are already present in ObjectMonitoringInterface.

Undo that change.

Resolves: #57271
Releases: 6.2
Change-Id: I95852d8221a1b54c4d6a71c508666e0fb1080223
Reviewed-on: https://review.typo3.org/28745
Reviewed-by: Xavier Perseguers
Reviewed-by: Helmut Hummel
Tested-by: Markus Klein
Reviewed-by: Markus Klein

History

#1 Updated by Markus Klein over 5 years ago

  • Status changed from New to Accepted
  • Assignee set to Markus Klein
  • Is Regression changed from No to Yes

Thanks for the report.
Problem of last patch merged before the rc2

#2 Updated by Markus Klein over 5 years ago

Which PHP version are you using? (exact version please)

#3 Updated by Markus Klein over 5 years ago

Related:
http://stackoverflow.com/questions/17525620/php-fatal-error-cant-inherit-abstract-function

Comment there:

I recently encountered this Problem as well. For me it helped upgrading from PHP 5.3.8 to PHP 5.3.28.

Some other comment:

... showing that it is fixed since PHP 5.3.9.

#4 Updated by Claus Harup over 5 years ago

PHP Version 5.3.8

#5 Updated by Markus Klein over 5 years ago

Ok found the real problem.

AbstractDomainObject implements DomainObjectInterface, \TYPO3\CMS\Extbase\Persistence\ObjectMonitoringInterface

Both interfaces now contain _memorizeCleanState() and _isDirty().

Will remove these again from DomainObjectInterface.

#6 Updated by Gerrit Code Review over 5 years ago

  • Status changed from Accepted to Under Review

Patch set 1 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/28745

#7 Updated by Ernesto Baschny over 5 years ago

  • Parent task set to #57031

#8 Updated by Markus Klein over 5 years ago

  • Status changed from Under Review to Resolved
  • % Done changed from 0 to 100

#9 Updated by Claus Harup over 5 years ago

Works again in TYPO3 6.2.0 on PHP 5.3.8 :-)

#10 Updated by Riccardo De Contardi about 2 years ago

  • Status changed from Resolved to Closed

Also available in: Atom PDF