Project

General

Profile

Actions

Bug #57408

closed

Call of the meta extractor services for local storage possible

Added by André Haehnel about 10 years ago. Updated over 6 years ago.

Status:
Closed
Priority:
Should have
Assignee:
-
Category:
-
Target version:
Start date:
2014-03-28
Due date:
% Done:

0%

Estimated time:
TYPO3 Version:
7
PHP Version:
Tags:
Complexity:
Is Regression:
No
Sprint Focus:

Description

It is currently not possible meta extractor services to be used for remote storages.
The indexer retrieves the services only for local file systems.


Related issues 1 (0 open1 closed)

Has duplicate TYPO3 Core - Feature #56726: Trigger MetaDataExtraction after file uploadClosed2014-03-10

Actions
Actions #1

Updated by Gerrit Code Review about 10 years ago

Patch set 2 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/28941

Actions #2

Updated by Gerrit Code Review about 10 years ago

Patch set 3 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/28941

Actions #3

Updated by Christian Weiske about 10 years ago

The problem is that TYPO3 relies on the sys_file_metadata data (width and height) when rendering images that do not need to be scaled.

This happens with content element "images only" with images < 100x100.

Deferred meta data extraction via a scheduler is not enough here; we need the correct sizes in the metadata record because typo3 renders width=0 and height=0 in HTML otherwise.

So our solution is to immediately fetch the file's meta data instead of waiting for the scheduler to run at night.

Actions #4

Updated by Gerrit Code Review about 10 years ago

Patch set 4 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/28941

Actions #5

Updated by Gerrit Code Review about 10 years ago

Patch set 5 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/28941

Actions #6

Updated by Gerrit Code Review about 10 years ago

Patch set 6 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/28941

Actions #7

Updated by Gerrit Code Review about 10 years ago

Patch set 7 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/28941

Actions #8

Updated by Anja Leichsenring almost 9 years ago

  • Project changed from 2264 to TYPO3 Core
  • Target version set to 7 LTS
Actions #9

Updated by Frans Saris almost 9 years ago

  • Status changed from New to Resolved
  • TYPO3 Version set to 7
  • Is Regression set to No

This is now possible see #56726

Actions #10

Updated by Riccardo De Contardi over 6 years ago

  • Status changed from Resolved to Closed
Actions

Also available in: Atom PDF