Bug #57415

Local driver does not sanitize directory names on recursive creation

Added by Alexander Stehlik about 7 years ago. Updated over 2 years ago.

Status:
Closed
Priority:
Should have
Assignee:
-
Category:
File Abstraction Layer (FAL)
Target version:
-
Start date:
2014-03-28
Due date:
% Done:

100%

Estimated time:
TYPO3 Version:
6.2
PHP Version:
5.4
Tags:
Complexity:
no-brainer
Is Regression:
Yes
Sprint Focus:

Description

The createFolder() method will not correctly sanitize the directory name parts, when the recursive option is TRUE (as used by TCE).

The reason for this is, that the return value of array_map is not used:



	

Regression introduced in #54230


Related issues

Related to TYPO3 Core - Task #54230: Refactor Driver APIClosedSteffen Ritter2013-12-062013-12-31

Actions
#1

Updated by Alexander Stehlik about 7 years ago

Actually there should be code in the description:

array_map(array($this, 'sanitizeFileName'), $parts);
#2

Updated by Gerrit Code Review about 7 years ago

  • Status changed from New to Under Review

Patch set 1 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/28940

#3

Updated by Gerrit Code Review about 7 years ago

Patch set 2 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/28940

#4

Updated by Alexander Stehlik about 7 years ago

  • Status changed from Under Review to Resolved
  • % Done changed from 0 to 100
#5

Updated by Benni Mack over 2 years ago

  • Status changed from Resolved to Closed

Also available in: Atom PDF