Bug #57809

Illegal string offset 'el' in ContentObjectRenderer.php

Added by Julian Wundrak about 7 years ago. Updated over 2 years ago.

Status:
Closed
Priority:
Must have
Assignee:
-
Category:
-
Target version:
Start date:
2014-04-10
Due date:
% Done:

100%

Estimated time:
TYPO3 Version:
6.2
PHP Version:
5.5
Tags:
Complexity:
Is Regression:
No
Sprint Focus:

Description

After upgrading from 6.1 to 6.2, there is an issue with rendering video-elements. I got an "Illegal string offset 'el'"-error in the ContentObjectRenderer.php.
I fixed this error by adding at line 1179 to the ContentObjectRenderer.php an if(isset($value['el'])) and add an isset to the if($value['vDEF']) some lines below.

Please add this to the mainline. Thanks


Related issues

Has duplicate TYPO3 Core - Bug #58169: Can't add Flash parameters when using content element "media"Closed2014-04-25

Actions
#1

Updated by Markus Klein about 7 years ago

Hi!

The code is not optimal, but your configuration seems to be faulty too.
Why is $value a string?

#2

Updated by Gerrit Code Review about 7 years ago

  • Status changed from New to Under Review

Patch set 1 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/29343

#3

Updated by Gerrit Code Review about 7 years ago

Patch set 2 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/29343

#4

Updated by Gerrit Code Review about 7 years ago

Patch set 3 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/29343

#5

Updated by Gerrit Code Review about 7 years ago

Patch set 4 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/29343

#6

Updated by Gerrit Code Review about 7 years ago

Patch set 5 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/29343

#7

Updated by Markus Klein about 7 years ago

  • Priority changed from Should have to Must have
  • Target version set to next-patchlevel
#8

Updated by Gerrit Code Review about 7 years ago

Patch set 1 for branch TYPO3_6-1 of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/29892

#9

Updated by Markus Klein about 7 years ago

  • Status changed from Under Review to Resolved
  • % Done changed from 0 to 100
#10

Updated by Benni Mack over 2 years ago

  • Status changed from Resolved to Closed

Also available in: Atom PDF