Bug #57827

AdminPanel: Link to list module is missing form token

Added by Robert Vock over 8 years ago. Updated over 8 years ago.

Status:
Closed
Priority:
Should have
Assignee:
-
Category:
-
Target version:
-
Start date:
2014-04-11
Due date:
% Done:

0%

Estimated time:
TYPO3 Version:
6.2
PHP Version:
Tags:
Complexity:
Is Regression:
No
Sprint Focus:

Description

There is a link to the list-module from the AdminPanel (see attached screenshot), which is not working.

The Link is missing the FormToken, because the FormProtectionFactory does not generate FormProtection in the frontend-context.
See getClassNameByState method in typo3/sysext/core/Classes/FormProtection/FormProtectionFactory.php

The generated link looks like this:
BASE/typo3/mod.php?M=web_list&moduleToken=dummyToken&id=1&returnUrl=%2F


Files


Related issues

Is duplicate of TYPO3 Core - Bug #57579: Improve admin panelClosedGeorg Ringer2014-04-02

Actions
#1

Updated by Markus Klein over 8 years ago

  • Status changed from New to Closed

Closing as duplicate of #57579

Also available in: Atom PDF