Project

General

Profile

Actions

Bug #58034

closed

RTE.default.buttons.blockstyle not configurable

Added by Renzo Bauen almost 10 years ago. Updated over 5 years ago.

Status:
Closed
Priority:
Must have
Category:
RTE (rtehtmlarea + ckeditor)
Target version:
Start date:
2014-04-18
Due date:
% Done:

100%

Estimated time:
TYPO3 Version:
6.2
PHP Version:
5.5
Tags:
Complexity:
Is Regression:
No
Sprint Focus:

Description

In TYPO3 6.2.0 and 6.2.1 i configure the RTE like this

RTE.default.contentCSS = fileadmin/rte.css
RTE.default.buttons.blockstyle {
showTagFreeClasses = 0
postfixLableWithClassName = 1
}

The Pull-Down-Box shows ever all classes in rte.css, independent of the settings for "showTagFreeClasses".

There is only one exception:
if i start editing a text and click on the Blockstyles-Pulldown bevor clicked somewhere in the textarea, the Pulldown shows the right list of classes. After a click in the textarea, all existing classes in rte.css are shown.

In 4.x this worked fine!
any "tags.div.allowedClasses = ..." has no effect for blockstyle

For RTE.default.buttons.textstyle everything works as expected. Here "showTagFreeClasses" and "allowedClasses" has the expected effect.

Actions #1

Updated by Markus Klein almost 10 years ago

  • Assignee set to Stanislas Rolland
Actions #2

Updated by Stanislas Rolland over 9 years ago

  • Status changed from New to Accepted
Actions #3

Updated by Gerrit Code Review over 9 years ago

  • Status changed from Accepted to Under Review

Patch set 1 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at http://review.typo3.org/33913

Actions #4

Updated by Stanislas Rolland over 9 years ago

  • Status changed from Under Review to Accepted
  • Target version set to next-patchlevel

I was able to reproduce this issue.

Two problems here:

1. BlockStyle and TextStyle plugins compete to load the same global classes configuration from PageTSconfig. However, this does not seem to be the root cause, since the behaviour remains erratic after fixing this.

2. Both plugins create an instance of HTMLArea.CSS.Parser. However, it seems that the object that contains the parsed classes of BlockStyle is reused (or re-applied?) and not re-initialized by the instance created by TextStyle. ExtJS bug?
After forcing the initialisation of the object in the class constructor, the problem is resolved... at least in all the tests I could make.

Actions #5

Updated by Gerrit Code Review over 9 years ago

  • Status changed from Accepted to Under Review

Patch set 2 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at http://review.typo3.org/33913

Actions #6

Updated by Stanislas Rolland over 9 years ago

  • Status changed from Under Review to Resolved
  • % Done changed from 0 to 100
Actions #7

Updated by Gerrit Code Review over 9 years ago

  • Status changed from Resolved to Under Review

Patch set 1 for branch TYPO3_6-2 of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at http://review.typo3.org/33914

Actions #8

Updated by Stanislas Rolland over 9 years ago

Please test this change: http://review.typo3.org/33914 for TYPO3 6.2.

Actions #9

Updated by Stanislas Rolland over 9 years ago

  • Status changed from Under Review to Resolved
Actions #10

Updated by Benni Mack over 5 years ago

  • Status changed from Resolved to Closed
Actions

Also available in: Atom PDF