Bug #58119

Using $query->statement causes exception

Added by Kilian Hann over 7 years ago. Updated over 7 years ago.

Status:
Closed
Priority:
Must have
Assignee:
-
Category:
Extbase
Target version:
-
Start date:
2014-04-23
Due date:
% Done:

0%

Estimated time:
TYPO3 Version:
6.2
PHP Version:
Tags:
Complexity:
Is Regression:
No
Sprint Focus:

Description

The following (simplified) repository method causes the exception 1302855001 with The property "statement" on the subject does not exist. in TYPO3 6.2.1 and 6.2.0:
Subject is TYPO3\CMS\Extbase\Persistence\Generic\QueryResult.

public function findByUids($uids = array()){
        $uids[] = -1;
        $query = $this->createQuery();
        $q = '
        SELECT
            *
        FROM
            tx_test_domain_model_test
        WHERE 1
            AND uid IN('.implode(',',$uids).')
        GROUP BY uid
        ORDER BY field(uid,' . implode(',', $uids) . ')
        ';
        $query->statement($q);
        return $query->execute();
    }

(it works fine in TYPO3 4.7.x)

#1

Updated by Marc Bastian Heinrichs over 7 years ago

  • Project changed from 534 to TYPO3 Core
  • Category deleted (Extbase: Generic Persistence)
#2

Updated by Marc Bastian Heinrichs over 7 years ago

  • Category set to Extbase
  • Target version set to next-patchlevel
  • Is Regression set to Yes
  • TYPO3 Version set to 6.2
#3

Updated by Oliver Hader over 7 years ago

  • Status changed from New to Needs Feedback
  • Is Regression changed from Yes to No

I could not reproduce this behaviour in the recent Git master (TYPO3 CMS 6.2.2).
The query statement worked as expected - I've also used WHERE, GROUP BY and ORDER BY like in your example.

Can you please test again with the recent Git master and if the issue still exists, please provide a PHP backtrace. Thanks in advance!

#4

Updated by Alexander Opitz over 7 years ago

  • Status changed from Needs Feedback to Closed
  • Target version deleted (next-patchlevel)

No feedback within the last 90 days => closing this issue.

If you think that this is the wrong decision or experience this issue again, then please write to the mailing list typo3.teams.bugs with issue number and an explanation or open a new ticket and add a relation to this ticket number.

Also available in: Atom PDF