Bug #58257

Not possible to close just localized record

Added by Helmut Hummel about 7 years ago. Updated over 2 years ago.

Status:
Closed
Priority:
Must have
Assignee:
-
Category:
-
Target version:
-
Start date:
2014-04-27
Due date:
% Done:

100%

Estimated time:
TYPO3 Version:
6.2
PHP Version:
Tags:
Complexity:
Is Regression:
Yes
Sprint Focus:

Description

When localizing a record in list module, edit view of the just localized record is shown.
After merge of #55314 it is not possible to close the record any more,
pressing the save and close or close button, re-opens the edit view again.


Related issues

Related to TYPO3 Core - Bug #55314: TableListViewHelper - pagination moves to List moduleClosed2014-01-24

Actions
#1

Updated by Markus Klein about 7 years ago

Hm, I'm not sure if we should revert the patch.
Why should "AbstractDatabaseRecordList" rely on a static value?

We should rather fix the list module to properly specify the module which has to be loaded.

I'll take a look.

#2

Updated by Markus Klein about 7 years ago

Ok the culprit is actually not the $urlParameters['M'] part but the $urlParameters = array_replace_recursive(GeneralUtility::_GET(), $urlParameters); part.

This causes the list module to trigger a redirect to the edit form again, because of the justLocalized get parameter being present.

#3

Updated by Gerrit Code Review about 7 years ago

  • Status changed from Accepted to Under Review

Patch set 1 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/29701

#4

Updated by Gerrit Code Review about 7 years ago

Patch set 2 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/29701

#5

Updated by Gerrit Code Review about 7 years ago

Patch set 3 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/29701

#6

Updated by Gerrit Code Review about 7 years ago

Patch set 4 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/29701

#7

Updated by Markus Klein about 7 years ago

  • Status changed from Under Review to Resolved
  • % Done changed from 0 to 100
#8

Updated by Benni Mack over 2 years ago

  • Status changed from Resolved to Closed

Also available in: Atom PDF