Bug #58466

Image Processing preset not properly detected

Added by Anja Leichsenring about 7 years ago. Updated over 2 years ago.

Status:
Closed
Priority:
Could have
Category:
Install Tool
Target version:
-
Start date:
2014-05-03
Due date:
% Done:

100%

Estimated time:
TYPO3 Version:
6.2
PHP Version:
Tags:
Complexity:
easy
Is Regression:
No
Sprint Focus:

Description

In case of active open_basedir restriction the detection of available Image Manipulation libraries might fail.
My setup tells the open_basedir allows /usr/bin/gm, but not /usr/bin. Therefor the condition is_dir(/usr/bin/) && @is_file(/usr/bin/gm) returns TRUE, where is_dir is FALSE and is_file is TRUE.
The is_dir($path) is superflous, because @is_file does the same and the
surpresses the PHP Warning anyway.
Conclusion: it does not hurt to remove the @is_dir condition alltogether and for such restricted the environments as mine detect the library properly.

#1

Updated by Gerrit Code Review about 7 years ago

  • Status changed from New to Under Review

Patch set 1 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/29822

#2

Updated by Gerrit Code Review about 7 years ago

Patch set 2 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/29822

#3

Updated by Gerrit Code Review about 7 years ago

Patch set 3 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/29822

#4

Updated by Gerrit Code Review about 7 years ago

Patch set 4 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/29822

#5

Updated by Anja Leichsenring about 7 years ago

  • Status changed from Under Review to Resolved
  • % Done changed from 0 to 100
#6

Updated by Benni Mack over 2 years ago

  • Status changed from Resolved to Closed

Also available in: Atom PDF