Bug #58528

config.prefixLocalAnchors causes GET parameters to be prepended to local anchors

Added by Artur Cichosz about 5 years ago. Updated over 4 years ago.

Status:
Rejected
Priority:
Should have
Assignee:
-
Category:
Content Rendering
Target version:
-
Start date:
2014-05-05
Due date:
% Done:

0%

TYPO3 Version:
6.1
PHP Version:
5.3
Tags:
Complexity:
Is Regression:
No
Sprint Focus:

Description

Hi,

I understand why the TS option config.prefixLocalAnchors is useful to prefix all local anchors with the relative path, but all GET parameters are prepended as well.

I do not think this is desired so it might be a bug.

Example:

Calling e.g. http://somehost.org/?test=abc results in local anchors like <a href="?test=abc#some_anchor">...</a>


Related issues

Related to TYPO3 Core - Bug #62723: Cache poisoning with prefixLocalAchors Closed 2014-11-05

History

#1 Updated by Markus Klein about 5 years ago

As far as I know this is not a bug. The feature prefixes the current url to the anchor. How should the Core know which parameters have to be removed and which need to be kept?

#2 Updated by Helmut Hummel over 4 years ago

  • Status changed from New to Rejected

Agreed, this is not a bug. This is how prefixLocalAchors works.

The only mitigation here is not use basURL at all and also not prefixLocalAchors, but just absRefPrefix

Also available in: Atom PDF