Bug #58719

Invalid form/module token in wizard

Added by Mathias Brodala almost 7 years ago. Updated over 2 years ago.

Status:
Closed
Priority:
Must have
Assignee:
-
Category:
Miscellaneous
Target version:
Start date:
2014-05-12
Due date:
% Done:

100%

Estimated time:
TYPO3 Version:
6.2
PHP Version:
Tags:
Complexity:
easy
Is Regression:
Yes
Sprint Focus:

Description

The OpenID wizard ("Add OpenID" next to the "OpenID identifier" backend user field) yields the following error upon submission of an OpenID identifier:

#1392409507: Invalid form/module token detected. Access Denied!

The issue occcurs due to an unnecessary `htmlspecialchars()` call in the `Wizard` class which yields an URL like this:

http://.../typo3/mod.php?M=wizard_openid&moduleToken=...

#1

Updated by Mathias Brodala almost 7 years ago

Forge is trying to be smarter than me:

http://.../typo3/mod.php?M=wizard_openid&moduleToken=...

Notice the &

#2

Updated by Markus Klein almost 7 years ago

  • Is Regression changed from No to Yes
#3

Updated by Gerrit Code Review almost 7 years ago

  • Status changed from New to Under Review

Patch set 1 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/30026

#4

Updated by Markus Klein almost 7 years ago

  • Status changed from Under Review to Resolved
  • % Done changed from 0 to 100
#5

Updated by Benni Mack over 2 years ago

  • Status changed from Resolved to Closed

Also available in: Atom PDF