Bug #58872

ResourceStorage::addFile throws exception due invalid file permission check

Added by Rico Sonntag over 5 years ago. Updated 3 months ago.

Status:
Closed
Priority:
Must have
Assignee:
-
Category:
File Abstraction Layer (FAL)
Target version:
-
Start date:
2014-05-16
Due date:
% Done:

0%

TYPO3 Version:
6.2
PHP Version:
Tags:
Complexity:
Is Regression:
No
Sprint Focus:

Description

/typo3/sysext/core/Classes/Resource/ResourceStorage.php => addFile

A call to addFile

$file = $resourceStorage->addFile(
    $pathToFile,
    $resourceStorage->getRootLevelFolder()
);

throws the exception "File name is invalid." (Code: 1320288991). Parameter $targetFileName is allowed to be empty but $this->assureFileAddPermissions does not take it into account. Instead the targetFileName is evaluated two lines later:

$targetFileName = $this->driver->sanitizeFileName($targetFileName ?: PathUtility::basename($localFilePath));

Do you really test your stuff before you release it (Commit 054207881d3be1d76b8205231c8847947d5c2e4c for instance)? Its a pain to work with TYPO3 6.2 and FAL. Really annoying.

History

#1 Updated by Mathias Schreiber almost 4 years ago

  • Target version deleted (next-patchlevel)

#2 Updated by Susanne Moog 7 months ago

  • Status changed from New to Needs Feedback

I cannot reproduce the issue. The code example in the description actually checks if the $targetFileName is empty and falls back to basename - so there does not seem to be a bug at all.

#3 Updated by Riccardo De Contardi 3 months ago

  • Status changed from Needs Feedback to Closed

No feedback since the last 90 days => closing this issue.

If you think that this is the wrong decision or experience the issue again and have more information about how to reproduce your problem, please reopen it or ping me.

Thank you and best regards

Also available in: Atom PDF