Bug #59391

recommendedMaxNestingLevel too low

Added by Thomas Christiansen about 8 years ago. Updated over 3 years ago.

Status:
Closed
Priority:
Should have
Assignee:
-
Category:
Install Tool
Target version:
-
Start date:
2014-06-06
Due date:
% Done:

100%

Estimated time:
TYPO3 Version:
6.2
PHP Version:
Tags:
Complexity:
Is Regression:
No
Sprint Focus:

Description

The recommended max nesting level of 250 is sometimes too low.

PHP Fatal error: Maximum function nesting level of '250' reached, aborting!


Related issues

Related to TYPO3 Core - Task #61523: Reduce error level of xdebug.max_nesting_level errorClosedNicole Cordes2014-09-11

Actions
#1

Updated by Gerrit Code Review about 8 years ago

  • Status changed from New to Under Review

Patch set 1 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/30608

#2

Updated by Gerrit Code Review about 8 years ago

Patch set 2 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/30608

#3

Updated by Anja Leichsenring about 8 years ago

can you elaborate, what the szenario was, when you broke the limit? Would be good to know, because when you run an edge case szenario, I would not increase the recommended value.

#4

Updated by Gerrit Code Review about 8 years ago

Patch set 3 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/30608

#5

Updated by Gerrit Code Review about 8 years ago

Patch set 1 for branch TYPO3_6-2 of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/30919

#6

Updated by Anonymous about 8 years ago

  • Status changed from Under Review to Resolved
  • % Done changed from 0 to 100
#7

Updated by Benni Mack over 3 years ago

  • Status changed from Resolved to Closed

Also available in: Atom PDF