Project

General

Profile

Actions

Bug #59610

closed

Implement multiple checkbox in CheckboxViewhelper

Added by Max Hellwig about 10 years ago. Updated over 5 years ago.

Status:
Closed
Priority:
Should have
Assignee:
-
Category:
Fluid
Target version:
Start date:
2014-06-16
Due date:
% Done:

0%

Estimated time:
TYPO3 Version:
6.2
PHP Version:
Tags:
Complexity:
Is Regression:
No
Sprint Focus:

Description

To cover the case of multivalue-checkboxes in TYPO3 Core Fluid CheckboxViewhelper I have applied implementation of the FLOW.Fluid CheckboxViewhelper.
I don't know whether it is enough but it looks like all to do is to change the method signature from

public function render($checked = NULL)

to
public function render($checked = NULL, $multiple = NULL)

and remove the @todo annotation in the representing if condition:
elseif (($multiple = FALSE) === TRUE) {
    // @todo: implement correct as in Flow.Fluid
    $nameAttribute .= '[]';
}

to
elseif ($multiple === TRUE) {
    $nameAttribute .= '[]';
}


Related issues 1 (0 open1 closed)

Is duplicate of TYPO3 Core - Bug #61529: Cannot ensure checkbox for multiple valuesClosedMathias Brodala2014-09-11

Actions
Actions #1

Updated by Gerrit Code Review about 10 years ago

  • Status changed from New to Under Review

Patch set 1 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/30756

Actions #2

Updated by Stefan Froemken over 9 years ago

  • Status changed from Under Review to Resolved
Actions #3

Updated by Benni Mack over 5 years ago

  • Status changed from Resolved to Closed
Actions

Also available in: Atom PDF