Bug #59972

Invalid mergeIfNotBlank usage in sys_file_reference TCA

Added by Alexander Stehlik almost 6 years ago. Updated over 1 year ago.

Status:
Closed
Priority:
Should have
Assignee:
-
Category:
Backend User Interface
Target version:
Start date:
2014-06-29
Due date:
% Done:

100%

TYPO3 Version:
6.2
PHP Version:
5.4
Tags:
Complexity:
easy
Is Regression:
No
Sprint Focus:

Description

Some fields in the sys_file_reference table currently are configured to behave as "mergeIfNotBlank" but this behavior is not respected in the Frontend. (and would not make sense there either).

Imagine this: You have a file and its metadata is translated in English and German.

Now you override the German translation in the file reference.

You probably do not want to use the german override for the English version. But you might want to remove the English description. The rendering in the Frontend currently behaves exactly like this. This is why the "mergeIfNotBlank" setting should be removed from the TCA to prevent confusion.


Related issues

Related to TYPO3 Core - Bug #59192: mergeIfNotBlank with FAL records Closed 2014-05-28

Associated revisions

Revision b0134053 (diff)
Added by Alexander Stehlik over 5 years ago

[BUGFIX] Improve l10n_mode config for sys_file_reference

Since the rendering in the Frontend does not merge the values
the mergeIfNotBlank setting is replaced with prefixLangTitle for
the alternative, description and title field.

For the link field the mergeIfNotBlank setting is removed because
a prefix does not make sense there.

Releases: 6.3, 6.2
Resolves: #59972
Change-Id: I242b687a7ce851270022b86561f13eacea4d3949
Reviewed-on: http://review.typo3.org/31212
Reviewed-by: Marcin Sągol <>
Reviewed-by: Frank Nägler <>
Tested-by: Frank Nägler <>
Reviewed-by: Anja Leichsenring <>
Tested-by: Anja Leichsenring <>

Revision f96c1013 (diff)
Added by Alexander Stehlik over 5 years ago

[BUGFIX] Improve l10n_mode config for sys_file_reference

Since the rendering in the Frontend does not merge the values
the mergeIfNotBlank setting is replaced with prefixLangTitle for
the alternative, description and title field.

For the link field the mergeIfNotBlank setting is removed because
a prefix does not make sense there.

Releases: 6.3, 6.2
Resolves: #59972
Change-Id: I242b687a7ce851270022b86561f13eacea4d3949
Reviewed-on: http://review.typo3.org/32756
Reviewed-by: Anja Leichsenring <>
Tested-by: Anja Leichsenring <>

Revision 4143a9b4 (diff)
Added by Alexander Stehlik almost 5 years ago

[BUGFIX] Improve l10n_mode config for sys_file_reference

Since the rendering in the Frontend does not merge the values
the mergeIfNotBlank setting is replaced with prefixLangTitle for
the alternative, description and title field.

For the link field the mergeIfNotBlank setting is removed because
a prefix does not make sense there.

Change-Id: I09dfd6d971357ceaeaa08f60057323b3c7e33aa1
Releases: master
Resolves: #59972
Reviewed-on: http://review.typo3.org/32758
Reviewed-by: Frank Nägler <>
Tested-by: Frank Nägler <>
Reviewed-by: Andreas Fernandez <>
Tested-by: Andreas Fernandez <>

History

#1 Updated by Gerrit Code Review almost 6 years ago

  • Status changed from New to Under Review

Patch set 1 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/31212

#2 Updated by Gerrit Code Review almost 6 years ago

Patch set 2 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/31212

#3 Updated by Gerrit Code Review almost 6 years ago

Patch set 3 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/31212

#4 Updated by Gerrit Code Review over 5 years ago

Patch set 1 for branch TYPO3_6-2 of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at http://review.typo3.org/32756

#5 Updated by Alexander Stehlik over 5 years ago

  • Status changed from Under Review to Resolved
  • % Done changed from 0 to 100

#6 Updated by Gerrit Code Review over 5 years ago

  • Status changed from Resolved to Under Review

Patch set 1 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at http://review.typo3.org/32758

#7 Updated by Gerrit Code Review over 5 years ago

Patch set 2 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at http://review.typo3.org/32758

#8 Updated by Markus Klein over 5 years ago

  • Description updated (diff)
  • Target version set to next-patchlevel
  • % Done changed from 100 to 0

Note: original patches have been reverted!

#9 Updated by Gerrit Code Review almost 5 years ago

Patch set 3 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at http://review.typo3.org/32758

#10 Updated by Gerrit Code Review almost 5 years ago

Patch set 4 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at http://review.typo3.org/32758

#11 Updated by Alexander Stehlik almost 5 years ago

  • Status changed from Under Review to Resolved
  • % Done changed from 0 to 100

#12 Updated by Benni Mack over 1 year ago

  • Status changed from Resolved to Closed

Also available in: Atom PDF