Project

General

Profile

Actions

Bug #60425

closed

RTE.classesAnchor.[ id-string ].titleText doesn't work

Added by Falk no-lastname-given over 9 years ago. Updated over 9 years ago.

Status:
Closed
Priority:
Must have
Category:
RTE (rtehtmlarea + ckeditor)
Target version:
Start date:
2014-07-21
Due date:
% Done:

0%

Estimated time:
TYPO3 Version:
6.2
PHP Version:
5.5
Tags:
Complexity:
Is Regression:
No
Sprint Focus:

Description

RTE.classesAnchor.[ id-string ].titleText seems to be ignored.

An other problem exists with the pageTsConfigs for typical and demo there is for titleText a wrong language file used (EXT:rtehtmlarea/res/accessibilityicons/locallang.xml).

Best
Falk


Related issues 2 (0 open2 closed)

Related to TYPO3 Core - Bug #62112: RTE references non-existent xml filesClosedStanislas Rolland2014-10-08

Actions
Related to TYPO3 Core - Feature #51905: Manage multiple classes attribution inside RTEClosed2013-09-11

Actions
Actions #1

Updated by Falk no-lastname-given over 9 years ago

  • Target version set to next-patchlevel
Actions #2

Updated by Stephan Vidar over 9 years ago

The same problem here! I need this in conjunction with bootstrap-framework to give a readable title...

RTE.classesAnchor.[btn btn-sm btn-primary].titleText = Nice Button

Actions #3

Updated by Stanislas Rolland over 9 years ago

Falk no-lastname-given wrote:

RTE.classesAnchor.[ id-string ].titleText seems to be ignored.

This is working for me. What id-string are you using?

Actions #4

Updated by Stanislas Rolland over 9 years ago

  • Status changed from New to Needs Feedback

Stephan Vidar wrote:

The same problem here! I need this in conjunction with bootstrap-framework to give a readable title...
[...]

This is also working fine for me with

RTE.default.buttons.link.properties.class.allowedClasses := addToList(btn btn-sm btn-primary)
RTE.classesAnchor.id_string.titleText = Nice button
RTE.classesAnchor.id_string.class = "btn btn-sm btn-primary" 
Actions #5

Updated by Stanislas Rolland over 9 years ago

Falk no-lastname-given wrote:

An other problem exists with the pageTsConfigs for typical and demo there is for titleText a wrong language file used (EXT:rtehtmlarea/res/accessibilityicons/locallang.xml).

This should not cause any problem. In fact, the English text is actually retrieved from the file. It seems however that this file is not translated on the translation server, perhaps because these texts will appear only if the accessible links feature is enabled in the extension configuration.

Actions #6

Updated by Stephan Vidar over 9 years ago

Ok - I think it's a misunderstanding and yes the titleText works... This bug can be closed. I'm looking for a way to give the editor a readable title within the selectbox. Because "btn btn btn-sm-primary" is not really meaningful and if listed here are several different classes is rapidly lost overview and significance.

Is there a way to adjust the label of the option within the selectbox?

Actions #7

Updated by Stanislas Rolland over 9 years ago

  • Assignee set to Stanislas Rolland

Stephan Vidar wrote:

Is there a way to adjust the label of the option within the selectbox?

I am not sure which selector box you are referring to.

In RTE.classesAnchor, you can use the titleText to specify the label. But this applies only to the link dialogue.

But in the case of the array RTE.classes, the "id string" IS the name of the class.

I guess you would need this feature: https://review.typo3.org/#/c/29643/

But only in TYPO3 CMS 7.0...

Actions #8

Updated by Stanislas Rolland over 9 years ago

  • Status changed from Needs Feedback to Closed
Actions

Also available in: Atom PDF