Bug #60497

[GFX][thumbnails] = 0 not working

Added by Wolfgang Hamster over 5 years ago. Updated over 1 year ago.

Status:
Closed
Priority:
Must have
Assignee:
-
Category:
Install Tool
Target version:
Start date:
2014-07-23
Due date:
% Done:

100%

TYPO3 Version:
6.2
PHP Version:
Tags:
Complexity:
Is Regression:
Yes
Sprint Focus:

Description

In the Install Tool I've set [GFX][thumbnails] to "0", but the thumbnails are still generated in Backend.

Is there a solution?


Related issues

Related to TYPO3 Core - Feature #33751: Make use of File Abstraction Layer in Backend Closed 2012-02-07

Associated revisions

Revision 77d988e1 (diff)
Added by Benni Mack about 4 years ago

[BUGFIX] Re-implement GFX[thumbnails] for Backend

The option to disable thumbnails globally for every
backend user in various places does not work anymore,
but is still quite useful. The patch re-introduces the option
to not show the thumbnail in various places.

Resolves: #60497
Releases: master
Change-Id: I28e8bf86563032df8008c7de9aa7861bb5c0e2c0
Reviewed-on: https://review.typo3.org/45138
Reviewed-by: Wouter Wolters <>
Reviewed-by: Georg Ringer <>
Tested-by: Georg Ringer <>
Reviewed-by: Daniel Goerz <>
Tested-by: Daniel Goerz <>
Reviewed-by: Andreas Fernandez <>
Reviewed-by: Morton Jonuschat <>
Tested-by: Morton Jonuschat <>

History

#1 Updated by Markus Klein over 5 years ago

Hi!

I checked all usages of this config option in the code.
Unfortunately, I have to tell you that this option is only used in FE when rending filelinks (stdWrap), but not at all in BE.
So clearly the description of this option is totally wrong and the option itself is totally outdated.

Where do you want to hide the thumbs?

#2 Updated by Wolfgang Hamster over 5 years ago

  • Assignee set to Markus Klein

Hi!

I have a (backend) page with over 200 textpic elements (translations included).
The page speed is very low, because the thumbnail rendering and the image loading took a while.

Have you an idea?

#3 Updated by Markus Klein over 5 years ago

Hm, seems like this was changed with 6.0 or 6.1.
I'm still searching for the commit.

#5 Updated by Markus Klein over 5 years ago

  • Status changed from New to Accepted
  • Assignee deleted (Markus Klein)
  • Is Regression changed from No to Yes

#6 Updated by Mathias Schreiber about 4 years ago

  • Target version set to next-patchlevel
For the brave person taking this one on:
  • Open typo3/sysext/core/Classes/Resource/Processing/LocalPreviewHelper.php on Line76
  • Move the call to $this->getTemporaryFilePath($task) away from here
Reasoning:
Getting the temp file name will actually CREATE the file.
So the file will always be generated even if there is no reason to do so.
Examples:
  • [GFX][thumbnails] = 0 is set.
  • The entire Graphic processing is disabled... you will still create empty files (because of the usage of tempnam() and filelist will go "hey, I have images to show"

#7 Updated by Gerrit Code Review about 4 years ago

  • Status changed from Accepted to Under Review

Patch set 1 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/45138

#8 Updated by Benni Mack about 4 years ago

  • Status changed from Under Review to Resolved
  • % Done changed from 0 to 100

#9 Updated by Benni Mack over 1 year ago

  • Status changed from Resolved to Closed

Also available in: Atom PDF