Bug #60567

'styles.*' object settings not shown in TSOB

Added by Anja Leichsenring over 5 years ago. Updated over 1 year ago.

Status:
Closed
Priority:
Should have
Category:
TypoScript
Target version:
-
Start date:
2014-07-25
Due date:
% Done:

100%

TYPO3 Version:
6.2
PHP Version:
Tags:
Complexity:
Is Regression:
No
Sprint Focus:

Description

No 'styles' part is shown in TypoScript Object Browser. This information might be useful during development, and there is no real reason to hide this information.

Associated revisions

Revision 9365def5 (diff)
Added by Anja Leichsenring over 5 years ago

[TASK] Show 'styles' object in TypoScript Object Browser

When you look in the TOB for the styles.* settings, those are not
shown. In order to ease the lookup of existing settings, let's
show them there.

Resolves: #60567
Releases: 6.3
Change-Id: I5163736c21847070c50e29911fff2b492f7cfc87
Reviewed-on: http://review.typo3.org/31814
Reviewed-by: Wouter Wolters <>
Tested-by: Wouter Wolters <>
Reviewed-by: Christian Kuhn <>
Tested-by: Christian Kuhn <>

Revision dfff617f (diff)
Added by Wouter Wolters over 5 years ago

[TASK] Remove hardcoded TypoScript setup

TypoScript TemplateService contains some hard coded TS that is always
present. The two defaults config.extTarget and config.uniqueLinkVars
are now moved to EXT:frontend and registered with the usual API call.
styles.insertContent is removed since it was always hidden in the
object browser and probably never used by anyone.

Change-Id: I8d0fd7c91e0c3b7ac19bcf1e435bb911b597e525
Resolves: #42543
Related: #60567
Releases: 6.3
Reviewed-on: http://review.typo3.org/20279
Reviewed-by: Christian Kuhn <>
Tested-by: Christian Kuhn <>
Reviewed-by: Anja Leichsenring <>
Tested-by: Anja Leichsenring <>
Reviewed-by: Benjamin Mack <>
Tested-by: Benjamin Mack <>

History

#1 Updated by Gerrit Code Review over 5 years ago

  • Status changed from New to Under Review

Patch set 1 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at http://review.typo3.org/31814

#2 Updated by Anja Leichsenring over 5 years ago

  • Status changed from Under Review to Resolved
  • % Done changed from 0 to 100

#3 Updated by Benni Mack over 1 year ago

  • Status changed from Resolved to Closed

Also available in: Atom PDF