Project

General

Profile

Actions

Bug #60649

closed

Resource/Filter/FileNameFilter doesn't filter files in hidden directories…

Added by zimmer7 UG (haftungsbeschränkt) over 9 years ago. Updated over 5 years ago.

Status:
Closed
Priority:
Must have
Assignee:
-
Category:
File Abstraction Layer (FAL)
Target version:
Start date:
2014-07-28
Due date:
% Done:

100%

Estimated time:
TYPO3 Version:
6.2
PHP Version:
5.5
Tags:
Complexity:
easy
Is Regression:
Yes
Sprint Focus:

Description

This leads to FAL indexing a whole git structure or whatever you have might have in a local storage.

Actions #1

Updated by Gerrit Code Review over 9 years ago

  • Status changed from New to Under Review

Patch set 1 for branch TYPO3_6-2 of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at http://review.typo3.org/31889

Actions #2

Updated by Markus Klein over 9 years ago

  • Priority changed from Should have to Must have
  • Target version set to next-patchlevel
  • Complexity set to easy
Actions #3

Updated by Gerrit Code Review over 9 years ago

Patch set 1 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at http://review.typo3.org/31890

Actions #4

Updated by Frans Saris over 9 years ago

Are "hidden" folders also hidden in 4.* versions? Else this would lead to a regression. And how about hidden folders on windows systems?

Actions #5

Updated by zimmer7 UG (haftungsbeschränkt) over 9 years ago

In 4.5 you see those directories with a leading dot, but as they are not indexed in any way, this is ok. With FAL, this can lead to massive performance problems… Why is this a regression, since 4.5 came without FAL?

And I can't say what hidden directories on Windows look like,… somebody else has to answer.

Actions #6

Updated by Frans Saris over 9 years ago

  • Is Regression changed from No to Yes

Had a look at the code of former versions and this has also a check on the dot.

Actions #7

Updated by Frans Saris over 9 years ago

  • Status changed from Under Review to Needs Feedback

Had a closer look at your patch. And the problem isn't the dot. But the problem is that the name is used for the check instead of the indentifier. Correct?

Actions #8

Updated by zimmer7 UG (haftungsbeschränkt) over 9 years ago

The problem, as far as I can remember after three months, is that the identifier doesn't start with a dot if it's at the root of the FAL storage, but with `/.`.

Actions #9

Updated by zimmer7 UG (haftungsbeschränkt) over 9 years ago

…and another bugfix release that doesn't address this issue :-(

Actions #10

Updated by Gerrit Code Review over 9 years ago

  • Status changed from Needs Feedback to Under Review

Patch set 2 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at http://review.typo3.org/31890

Actions #11

Updated by Gerrit Code Review over 9 years ago

Patch set 3 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at http://review.typo3.org/31890

Actions #12

Updated by Gerrit Code Review over 9 years ago

Patch set 4 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at http://review.typo3.org/31890

Actions #13

Updated by Gerrit Code Review over 9 years ago

Patch set 5 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at http://review.typo3.org/31890

Actions #14

Updated by Gerrit Code Review over 9 years ago

Patch set 6 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at http://review.typo3.org/31890

Actions #15

Updated by Gerrit Code Review over 9 years ago

Patch set 7 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at http://review.typo3.org/31890

Actions #16

Updated by Gerrit Code Review over 9 years ago

Patch set 8 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at http://review.typo3.org/31890

Actions #17

Updated by Gerrit Code Review over 9 years ago

Patch set 9 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at http://review.typo3.org/31890

Actions #18

Updated by Gerrit Code Review over 9 years ago

Patch set 2 for branch TYPO3_6-2 of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at http://review.typo3.org/31889

Actions #19

Updated by Gerrit Code Review over 9 years ago

Patch set 3 for branch TYPO3_6-2 of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at http://review.typo3.org/31889

Actions #20

Updated by zimmer7 UG (haftungsbeschränkt) over 9 years ago

  • Status changed from Under Review to Resolved
  • % Done changed from 0 to 100
Actions #21

Updated by Benni Mack over 5 years ago

  • Status changed from Resolved to Closed
Actions

Also available in: Atom PDF