Bug #60821

Migrate all file relations from tt_content.image delete files and not migrate

Added by Michal Cygankiewicz over 6 years ago. Updated over 4 years ago.

Status:
Closed
Priority:
Should have
Assignee:
-
Category:
Install Tool
Target version:
-
Start date:
2014-08-06
Due date:
% Done:

0%

Estimated time:
TYPO3 Version:
6.2
PHP Version:
Tags:
Complexity:
Is Regression:
No
Sprint Focus:

Description

I try to make upgrade from 4.5 to 6.2.

After executing step 'Migrate all file relations from tt_content.image and pages.media' in Upgrade Wizard I get quite a lot of errors:

"File 'uploads/pics/[FILENAME].jpg' does not exist. Referencing field: tt_content.63202.image. The reference was not migrated."

1. At first I thought the file is not in place. So I checked that and actually the file wasn't there.
2. I checked if file is in original live server - it was there.
3. So I copy this (and others) files that was missing from live to my pilot upgrade once more - so I was sure all files are in place now.
4. After executing 'Migrate all file relations from tt_content.image and pages.media' it still displays the same errors. Additionally the files which are mentioned in errors are deleted after executing this step.

In my case 'Migrate all file relations from tt_content.image and pages.media' converted a lot of cases properly but also quite a lot not...

#1

Updated by Wouter Wolters over 4 years ago

  • Status changed from New to Needs Feedback

Did this happen again with a newer version of 6.2?
In the beginning there were a few problems with the upgrade wizard...

#2

Updated by Riccardo De Contardi over 4 years ago

  • Status changed from Needs Feedback to Closed

No feedback within the last 90 days => closing this issue.

If you think that this is the wrong decision or experience this issue again, then please write to the mailing list typo3.teams.bugs with issue number and an explanation or open a new ticket and add a relation to this ticket number.

Also available in: Atom PDF