Bug #60853

The FAL indexer should detect moved files

Added by Nils Blattner over 6 years ago. Updated over 4 years ago.

Status:
Closed
Priority:
Should have
Assignee:
-
Category:
File Abstraction Layer (FAL)
Target version:
-
Start date:
2014-08-08
Due date:
% Done:

0%

Estimated time:
TYPO3 Version:
6.2
PHP Version:
Tags:
Complexity:
Is Regression:
No
Sprint Focus:

Description

When a file is moved by an external tool (shell/ftp/etc.), the indexer should detect this and update the sys_file record for that.

Currently it marks the old sys_file missing and creates a new one.

Cheers Nils

#1

Updated by Frans Saris over 6 years ago

  • Status changed from New to Needs Feedback

What version are you using?

6.2 supports this, but only if changes are detected by indexer task and files moved in same storage.

#2

Updated by Nils Blattner over 6 years ago

Tested on 6.2.4, moved a file inside the same folder. As said it reports the file missing and creates a new sys_file. It will not create a new file if there is already a missing file with the same name and hash (rename back).

Cheers

#3

Updated by Alexander Opitz over 6 years ago

Did you run the indexer task after moving?

#4

Updated by Nils Blattner over 6 years ago

Hi Alexander

Yes, after each move operation.

#5

Updated by Alexander Opitz over 6 years ago

  • Tracker changed from Feature to Bug
  • Status changed from Needs Feedback to New
  • TYPO3 Version set to 6.2
  • Is Regression set to No
#6

Updated by Frank Naegler over 6 years ago

I think this could be fixed with https://review.typo3.org/#/c/32000/ can you check this?

#7

Updated by Nils Blattner over 6 years ago

Hi Frank

I probably won't have the time to setup a test environment tomorrow and will be gone for two weeks after that.
What I did to test it was simple:
  • make sure a file is indexed
  • mv file file2
  • run indexer
  • check mysql tables => old record is missing and a new record appears
#8

Updated by Daniel Goerz over 4 years ago

  • Status changed from New to Closed

I am closing this ticket because when performing the steps to reproduce the bug in current master as well as in 7.6 the database record is updated as expected and not created again.

If you still think there is a bug that needs to be addressed, please do not hesitate to reopen the ticket or fie a new one with according description on how to reproduce.

Also available in: Atom PDF