Bug #61168

Installtool does not start because of eval'd code

Added by Stefan Froemken over 6 years ago. Updated over 6 years ago.

Status:
Closed
Priority:
Should have
Assignee:
-
Category:
Install Tool
Target version:
Start date:
2014-08-25
Due date:
% Done:

0%

Estimated time:
TYPO3 Version:
6.2
PHP Version:
5.4
Tags:
Complexity:
easy
Is Regression:
No
Sprint Focus:

Description

Hello Core-Team,

if you have multi-row comments /* ... */ in your localconf.php (TYPO3 4.5) the Installtool of TYPO3 6.2 will not start after upgrading, because of eval'd code:

Fatal error: Cannot use string offset as an array in /kunden/168185_70794/rp-hosting/5335/6335/typo3cms/typo3_src-6.2.4/typo3/sysext/install/Classes/Controller/StepController.php(236) : eval()'d code on line 125

After deleting the commented lines Installtool works as expected.

Stefan

#1

Updated by Gerrit Code Review over 6 years ago

  • Status changed from New to Under Review

Patch set 1 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at http://review.typo3.org/32339

#2

Updated by Gerrit Code Review over 6 years ago

Patch set 2 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at http://review.typo3.org/32339

#3

Updated by Mathias Schreiber over 6 years ago

  • Target version changed from next-patchlevel to 7.4 (Backend)
#4

Updated by Wouter Wolters over 6 years ago

  • Status changed from Under Review to Closed

Stefan Froemken Dec 22 08:48

Abandoned

It's not a topic anymore

Also available in: Atom PDF