Bug #61183

RTE: Internal links opens as external when created with Firefox

Added by Stig Nørgaard Færch almost 7 years ago. Updated over 6 years ago.

Status:
Rejected
Priority:
Should have
Category:
RTE (rtehtmlarea + ckeditor)
Target version:
-
Start date:
2014-08-26
Due date:
% Done:

0%

Estimated time:
TYPO3 Version:
4.5
PHP Version:
5.3
Tags:
Complexity:
Is Regression:
No
Sprint Focus:

Description

Link made with Chrome:

<a href="http://www.xn--brnegruppen-ggb.dk/?id=1139" class="internal-link" title="Opens internal link in current window">Test with Chrome</a>


Same link made with Firefox 30.0 and 31.0
<a href="http://børnegruppen.dk/?id=1139" class="internal-link" title="Opens internal link in current window" external="1">Same test with Firefox</a>

#1

Updated by Markus Klein almost 7 years ago

There is a similar problem with RTE on current master (6.3) with internal links being marked external.
However, I don't know if it is FF only.

#2

Updated by Stanislas Rolland almost 7 years ago

I am unable to reproduce this behaviour with TYPO3 6.2.5-dev and Firefox 32.0.3. Maybe there was a bug in FF 30 and 31?

#3

Updated by Stanislas Rolland almost 7 years ago

  • Status changed from New to Needs Feedback
#4

Updated by Stanislas Rolland almost 7 years ago

Are you using any typolinkLinkHandler?

#5

Updated by Stanislas Rolland over 6 years ago

Is this still an issue? I am unable to reproduce it with current master and FF 33.0.3.

#6

Updated by Stanislas Rolland over 6 years ago

I am unable to reproduce this behaviour in Firefox 35.0.

#7

Updated by Stanislas Rolland over 6 years ago

I just noticed that the domains are not the same... Are you logging in under the same domain with FF and with Chrome?

#8

Updated by Stanislas Rolland over 6 years ago

  • Status changed from Needs Feedback to Rejected
  • Assignee set to Stanislas Rolland

If you enter a link on the External link tab, the link will always be marked as external.

Also available in: Atom PDF