Project

General

Profile

Actions

Bug #61558

closed

IRRE: RTE does not load in Development preset if it is the first new created IRRE-Child

Added by Heiko Nöthen almost 10 years ago. Updated over 5 years ago.

Status:
Closed
Priority:
Must have
Assignee:
-
Category:
RTE (rtehtmlarea + ckeditor)
Target version:
-
Start date:
2014-09-12
Due date:
% Done:

0%

Estimated time:
TYPO3 Version:
6.2
PHP Version:
Tags:
Complexity:
Is Regression:
No
Sprint Focus:

Description

Hi,

1. Developer preset is active
2. Editing a content element with an IRRE field which has no elements yet. Click on "Create new Page Content" - then i get the message: The editor is being loaded. Please wait...

JS Console:
TypeError: ct is null ext-all-debug.js:11644
ReferenceError: HTMLArea is not defined editor-mode.js:16
ReferenceError: HTMLArea is not defined default-inline.js:16
ReferenceError: HTMLArea is not defined block-elements.js:16
TypeError: HTMLArea.I18N is undefined htmlarea.js:43

You can use jfmulticontent for example (View: Inline content). I have the same problem with my own extension.

3. When i save the content anyway the RTE is loaded without an error.

4. If i switch back to Production preset there is no problem with the RTE - even in the first new created IRRE child. After click on "Create new Page Content" the RTE is loaded.

Greetings,
Heiko

Actions #1

Updated by Daniel Ostmann over 9 years ago

It seems that this occurrs only in IRRE - RTEs.

Actions #2

Updated by Zoran Ilic over 9 years ago

Yes. I have the similar issue when I want to add content element with RTE from IRRE. Sometimes I can't even expand a content element with type 'text' which is using RTE.
I have the fallowing error messages in a console:
"ReferenceError: HTMLArea is not defined"
HTMLArea.EditorMode = Ext.extend(HTMLArea.Plugin, {...

...and the same error goes for "HTMLArea.TYPO3Link, HTMLArea.FindReplace, HTMLArea.FindReplace, HTMLArea.RemoveFormat, HTMLArea.DefaultClean, HTMLArea.ContextMenu, HTMLArea.UndoRedo, HTMLArea.CopyPaste, HTMLArea.I18N, HTMLArea.DefaultInline, HTMLArea.BlockElements, HTMLArea.CharacterMap" etc.

Actions #3

Updated by Zoran Ilic over 9 years ago

A similar problem regarding the IRRE RTE error is submited 2 years ago:
https://forge.typo3.org/issues/44617

Actions #4

Updated by Jan Kornblum over 9 years ago

Same problem here with RTE in IRRE + development preset.

Actions #5

Updated by Michael Kasten about 9 years ago

Confirm: Same Problem here at T3 Version: 6.2.12 with activatet developement preset

Actions #6

Updated by Riccardo De Contardi over 8 years ago

  • Category set to RTE (rtehtmlarea + ckeditor)
Actions #7

Updated by Benni Mack over 8 years ago

  • Status changed from New to Resolved

This fix was a bit harder to solve - we actually had to change the whole architecture of the IRRE resolving, which led to a breaking behaviour - that's why we solved this for v7 only (and could not backport this change to 6.2). Upgrading to v7 helps though. If you have further questions regarding this issue, feel free to contact me via Slack (https://forger.typo3.org/slack/)

Actions #8

Updated by Benni Mack over 5 years ago

  • Status changed from Resolved to Closed
Actions

Also available in: Atom PDF