Bug #61563

creating new file/folder from the context menu fails.

Added by Tymoteusz Motylewski over 6 years ago. Updated over 2 years ago.

Status:
Closed
Priority:
Should have
Assignee:
-
Category:
-
Target version:
-
Start date:
2014-09-13
Due date:
% Done:

0%

Estimated time:
TYPO3 Version:
6.2
PHP Version:
Tags:
Complexity:
Is Regression:
No
Sprint Focus:

Description

creating new file/folder from the context menu fails.

How to reproduce:
1. go to file list module
2. click on the folder icon on the list
3. select "new"
you will see following error:


Not Found

The requested URL /typo3/file_newfolder.php&target=1:/default/templates/extensions/tx_news/Templates/Administration/&returnUrl=/typo3/mod.php?M=file_list&moduleToken=304c812fc03183cd1b16e1da6f89a459b2f0951f&id=1%3A%2Fdefault%2Ftemplates%2Fextensions%2Ftx_news%2FTemplates%2F was not found on this server.

tested on e322b5f3d6396edba41d01d1ce4265afb2a2ca25


Related issues

Related to TYPO3 Core - Task #61215: Make file_newfolder.php dispatchedClosedWouter Wolters2014-08-26

Actions
#1

Updated by Tymoteusz Motylewski over 6 years ago

the problem is that the first parameter is added with "&" instead of "?"

#2

Updated by Tymoteusz Motylewski over 6 years ago

the patch from https://review.typo3.org/#/c/32405/2 also solves this issue.
The question is whether this problem also occures on 6.2 and if yes, how to solve it there.

#3

Updated by Felix Kopp over 6 years ago

Is this issue resolved?

#4

Updated by Tymoteusz Motylewski over 6 years ago

on 6.3 yes, need to check what about 6.2

#5

Updated by Mateusz Wojtuła over 6 years ago

I have checked it in TYPO3 6.2.4-dev and it works correctly.

#6

Updated by Benni Mack over 6 years ago

  • Status changed from New to Resolved

works as expected now.

#7

Updated by Benni Mack over 2 years ago

  • Status changed from Resolved to Closed

Also available in: Atom PDF