Bug #61565

PHP Strict Warning with v4.7 and MySQL5.4

Added by Rene S. about 5 years ago. Updated about 5 years ago.

Status:
Rejected
Priority:
Should have
Assignee:
-
Category:
-
Target version:
-
Start date:
2014-09-13
Due date:
% Done:

0%

TYPO3 Version:
4.7
PHP Version:
5.4
Tags:
Complexity:
Is Regression:
No
Sprint Focus:

Description

Opening a page in the FE gives

PHP Strict Standards: Non-static method tslib_cObj::getKey() should not be called statically, assuming $this from incompatible context in typo3\sysext\cms\tslib\class.tslib_menu.php on line 178
Same mistake in
typo3\sysext\cms\tslib\class.tslib_menu.php on line 605 and
typo3\sysext\cms\tslib\class.tslib_menu.php on line 606

This error was fixed for Typo3 V6 but not in the v4.7 branch.

Many Thanks Rene

History

#1 Updated by Gerrit Code Review about 5 years ago

  • Status changed from New to Under Review

Patch set 2 for branch TYPO3_4-7 of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at http://review.typo3.org/33255

#2 Updated by Stefan Froemken about 5 years ago

Hmmm...I just have created a patch for this issue, but maintenance ends just this month. So it could be, that this patch will not made it into TYPO3 4.7. Lets see what the core team think about it.

Stefan

#3 Updated by Christian Kuhn about 5 years ago

  • Status changed from Under Review to Rejected

Thanks for your bug report, Rene. Unfortunately, this will not be solved in 4.7 anymore:

  • I think we fixed that in younger versions already, and I also roughly remember some regression after we did it.
  • This patch is not trivial to verify, and includes 3rd party callers: It is very well possible that some of the calling methods are currently called statically by itself. If those now call $this, you'll get a fatal.
  • 4.7 is e-o-l since 10/2014, so it shouldn't even get security related patches anymore.

All in all, risk / benefit of this patch is not good enough to consider further reviews in the current state of 4.7 maintenance. The issues will be closed as "won't fix".

Also available in: Atom PDF