Bug #61952

bug dbType for date before 01-01-1970

Added by BIDAU Ismaƫl almost 5 years ago. Updated almost 4 years ago.

Status:
Closed
Priority:
Should have
Assignee:
-
Category:
-
Target version:
-
Start date:
2014-09-29
Due date:
% Done:

0%

TYPO3 Version:
6.2
PHP Version:
Tags:
Complexity:
Is Regression:
No
Sprint Focus:

Description

set a TCA field like this :
'birthday' => array (
'exclude' => 1,
'label' => 'LLL:EXT:ensci_contacts/Resources/Private/Language/locallang_db.xml:fe_users.birthday',
'config' => array (
'type' => 'input',
'dbType' => 'date',
'size' => '10',
'max' => '10',
'eval' => 'date'
)
),
For birthday > 01-01-1970, no problem.
For birthday < 01-01-1970, the display date is one day before the date that is in the database. Each time you click save button, the birthday is one day before !


Related issues

Related to TYPO3 Core - Feature #61110: Support for timezones in all date fields in TYPO3 BE New 2014-08-21
Related to TYPO3 Core - Bug #37244: TCA date evaluation for dates lower 01-01-1970 fails Accepted 2012-05-17
Related to TYPO3 Core - Bug #69290: Dates get reduced by a day if before 1970 Closed 2015-08-24

History

#1 Updated by Stefan Neufeind almost 5 years ago

It a problem with timezone-handling. Would be solved with #61110.

#2 Updated by Markus Klein about 4 years ago

Also related to #37244 I guess

#3 Updated by Riccardo De Contardi almost 4 years ago

  • Status changed from New to Closed

I close this as it is a duplicate of #69290 please continue the discussion there (I also added the related issues of this issue there)

If you think that this is the wrong decision, then please write to the mailing list typo3.teams.bugs with issue number and an explanation or open a new ticket and add a relation to this ticket number.

Also available in: Atom PDF