Bug #62133

Contentelement Wizard and TSConfig misbehaviour

Added by Kaan Sanli almost 5 years ago. Updated almost 3 years ago.

Status:
Closed
Priority:
Should have
Assignee:
-
Category:
FormEngine aka TCEforms
Target version:
-
Start date:
2014-10-09
Due date:
% Done:

0%

TYPO3 Version:
6.2
PHP Version:
Tags:
Complexity:
Is Regression:
No
Sprint Focus:

Description

The content element wizard ignores the CType textpic when using TSConfig TCEFORM.tt_content.CType.keepItems = textpic

This bug is already solved (see: #23864), but the patch was only applied for 6.1.


Related issues

Related to TYPO3 Core - Bug #23864: TCEFORM.tt_content.CType.keepItems = textpic does not work. Closed 2010-10-28

History

#1 Updated by Kaan Sanli almost 5 years ago

I've just seen, that there already has been a patch for 6.2 ([[https://review.typo3.org/#/c/27588/]]), but the bug is occurring again (tested in 6.2.5).

So, is this a regression?

#2 Updated by Markus Klein almost 5 years ago

Did you try TCEFORM.tt_content.ctype.keepItems ?

#3 Updated by Kaan Sanli almost 5 years ago

I've tried the above, but this is ignored.

If I use

TCEFORM.tt_content.CType.keepItems = text,textpic,17

the contentelement wizard shows me the items for text and textpic.

#4 Updated by Markus Klein almost 5 years ago

Ok, thanks for trying.

To summarize:

working

TCEFORM.tt_content.CType.keepItems = text,textpic

not working

TCEFORM.tt_content.CType.keepItems = text,textpic,17 # Element 17 is missing
TCEFORM.tt_content.CType.keepItems = textpic # No element is shown

Please correct me, if this is wrong.

#5 Updated by Kaan Sanli almost 5 years ago

I have found the reson, why this bug is occurring in my installation.

First of all, the applied patch for 6.2 works fine

TCEFORM.tt_content.CType.keepItems = text,textpic

I can choose text and textpic

But in my page TSConfig I use

TCEFORM.tt_content.imageorient.keepItems = 0,25,26

to keep only some types of imageorient
Result: No textpic item available in contentelement wizard

If I add the 17 again

TCEFORM.tt_content.imageorient.keepItems = 0,25,26,17

which is checked by the contentelement wizard in its default values

tt_content_defValues { CType = textpic imageorient = 17 }

the textpic item is shown again in the contentelement wizard.

#6 Updated by Markus Klein almost 5 years ago

  • Status changed from New to Needs Feedback
  • Target version deleted (next-patchlevel)

Thanks for sharing your findings.

Can I close this issue for now?

#7 Updated by Kaan Sanli almost 5 years ago

I would't close the ticket, because from my point of view, it is still a bug that "TCEFORM.tt_content.imageorient.keepItems = ..." is interfering in "TCEFORM.tt_content.CType.keepItems = ..."
concerning the contentelement wizard.
Instead I would change the subject of this ticket to somewhat like "Contentelement Wizard and TSConfig misbehaviour" and change the priority to "should have".

But feel free to close this ticket, if you have another opinion about it or if this bug can't be fixed in the near future.

#8 Updated by Markus Klein almost 5 years ago

  • Subject changed from Contentelement Wizard and TCEFORM.tt_content.CType.keepItems = textpic to Contentelement Wizard and TSConfig misbehaviour
  • Category set to FormEngine aka TCEforms
  • Status changed from Needs Feedback to Accepted
  • Priority changed from Must have to Should have
  • Target version set to next-patchlevel

#9 Updated by Philipp Kitzberger about 4 years ago

Seems to be still an issue for 6.2.11

#10 Updated by Riccardo De Contardi about 4 years ago

It is still a problem in both 6.2.13 and 7 (latest master): I can confirm that the following Page TSConfig:

TCEFORM.tt_content.imageorient.keepItems = 0,25,26

Makes "text with images" disappear in the new element wizard.

#11 Updated by Riccardo De Contardi over 3 years ago

still present on latest 7.6-dev (latest master)

#12 Updated by Markus Klein over 3 years ago

  • Target version deleted (next-patchlevel)

#13 Updated by Riccardo De Contardi about 3 years ago

I can confirm it still affects the 7.6.5 but seems fixed in the latest master (8.1-dev). Can someone confirm? Thank you

#14 Updated by Riccardo De Contardi almost 3 years ago

As far as I can see from my last test, TYPO3 7.6.11 and 8.5-dev (latest master) are not affected by this issue, while TYPO3 6.2.26 still is.

Do you think it is sufficient to consider it closed?

#15 Updated by Markus Klein almost 3 years ago

  • Status changed from Accepted to Closed

Thanks for checking Riccardo!

Closing this ticket for the time being as 6.2 is in priority bugfix mode only.

Also available in: Atom PDF