Bug #62147

TCA eval 'email' for validating e-mail addresses

Added by Olle Haerstedt about 5 years ago. Updated about 1 year ago.

Status:
Closed
Priority:
Should have
Category:
-
Target version:
Start date:
2014-10-10
Due date:
% Done:

100%

Estimated time:
2.00 h
TYPO3 Version:
6.2
PHP Version:
5.3
Tags:
Complexity:
easy
Is Regression:
No
Sprint Focus:

Description

Add an additional 'eval' option for the TCA: email. This will validate
that the entered value is a valid e-mail address using PHP FILTER_VALIDATE_EMAIL.
If the e-mail is not valid, a flash error message will show.


Related issues

Duplicates TYPO3 Core - Feature #15147: TCA: possibility to evaluate email fields Closed 2005-10-22

Associated revisions

Revision e350e867 (diff)
Added by Olle Haerstedt about 5 years ago

[FEATURE] A new eval option in TCA: email

Add a new eval option called 'email' to validate e-mail addresses.
If validation fails, a flash error message will be shown.

Resolves: #62147
Releases: master
Change-Id: Ie3885aa55a3fde95832fec163bc9347f06b4f54b
Reviewed-on: http://review.typo3.org/33251
Reviewed-by: Stefan Froemken <>
Tested-by: Stefan Froemken <>
Reviewed-by: Markus Klein <>
Tested-by: Markus Klein <>

History

#1 Updated by Gerrit Code Review about 5 years ago

  • Status changed from New to Under Review

Patch set 1 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at http://review.typo3.org/33251

#2 Updated by Gerrit Code Review about 5 years ago

Patch set 2 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at http://review.typo3.org/33251

#3 Updated by Gerrit Code Review about 5 years ago

Patch set 3 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at http://review.typo3.org/33251

#4 Updated by Gerrit Code Review about 5 years ago

Patch set 4 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at http://review.typo3.org/33251

#5 Updated by Georg Ringer about 5 years ago

I would be in favor of waiting a bit because we are planing to add all of those HTML5 input options to the FormEngine which makes it possible to have this feature out of the box!

#6 Updated by Gerrit Code Review about 5 years ago

Patch set 5 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at http://review.typo3.org/33251

#7 Updated by Gerrit Code Review about 5 years ago

Patch set 6 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at http://review.typo3.org/33251

#8 Updated by Gerrit Code Review about 5 years ago

Patch set 7 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at http://review.typo3.org/33251

#9 Updated by Gerrit Code Review about 5 years ago

Patch set 8 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at http://review.typo3.org/33251

#10 Updated by Gerrit Code Review about 5 years ago

Patch set 9 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at http://review.typo3.org/33251

#11 Updated by Gerrit Code Review about 5 years ago

Patch set 10 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at http://review.typo3.org/33251

#12 Updated by Gerrit Code Review about 5 years ago

Patch set 11 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at http://review.typo3.org/33251

#13 Updated by Gerrit Code Review about 5 years ago

Patch set 12 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at http://review.typo3.org/33251

#14 Updated by Gerrit Code Review about 5 years ago

Patch set 13 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at http://review.typo3.org/33251

#15 Updated by Gerrit Code Review about 5 years ago

Patch set 14 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at http://review.typo3.org/33251

#16 Updated by Gerrit Code Review about 5 years ago

Patch set 15 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at http://review.typo3.org/33251

#17 Updated by Patrick Schriner about 5 years ago

None of the old "eval" options output a flashmessage. I know it doesn't look as nice, but without the flash message code (which looks a lot like duplicate code in the same class anyway) the code would be much simpler:

 if (!GeneralUtility::validEmail($value)) {
     $set = FALSE;
     $value = '';
 }

Furthermore the method checkValue_input_Eval is public. You can't be for sure that someone isn't using this to do some evaluation and doesn't expect output in form of a flash message.

#18 Updated by Gerrit Code Review about 5 years ago

Patch set 16 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at http://review.typo3.org/33251

#19 Updated by Olle Haerstedt about 5 years ago

  • Status changed from Under Review to Resolved
  • % Done changed from 0 to 100

#20 Updated by Benni Mack about 1 year ago

  • Status changed from Resolved to Closed

Also available in: Atom PDF