Bug #62257

TCAdefaults are not respected when creating a page via drag'n'drop

Added by Thomas Balko over 7 years ago. Updated over 6 years ago.

Status:
Closed
Priority:
Should have
Assignee:
-
Category:
-
Target version:
-
Start date:
2014-10-15
Due date:
% Done:

0%

Estimated time:
TYPO3 Version:
6.2
PHP Version:
Tags:
Complexity:
Is Regression:
No
Sprint Focus:

Description

When creating a page inside the pagetree via drag'n'drop UserTSconfig TCAdefaults are not evaluated.

For Example:

I´ve created an User with the following TSconfig

TCAdefaults.pages.l18n_cfg = 2

This should check the "Hide page if no translation for current language exists" option in the behaviour tab.
While this works fine when the page is created with the list module, it has absolutely no effect when created via drag'n'drop.

I found an older related issue that says the bug should be fixed, but the problem seems the same.
https://forge.typo3.org/issues/25021


Related issues

Related to TYPO3 Core - Bug #59383: Create page via drag'n'drop does not respect TCAdefaults from UserTSClosed2014-06-06

Actions
Related to TYPO3 Core - Bug #46316: TCAdefaults in User tsconfig not working page created via pagetreeClosed2013-03-15

Actions
#1

Updated by Juan Manuel Vergés Solanas over 7 years ago

This is not working:
[page|doktype = 70]
TCAdefaults.pages.tx_fed_page_controller_action=m8thlayout->Layout
[GLOBAL]
This is working:
TCAdefaults.pages.tx_fed_page_controller_action=m8thlayout->Layout

Why?

#2

Updated by Riccardo De Contardi over 6 years ago

  • Status changed from New to Closed

I close this as it is a duplicate of #59383, please continue the discussion there.

If you think that this is the wrong decision, then please write to the mailing list typo3.teams.bugs with issue number and an explanation or open a new ticket and add a relation to this ticket number.

Also available in: Atom PDF