Bug #59383

Create page via drag'n'drop does not respect TCAdefaults from UserTS

Added by Konrad Schiertz over 5 years ago. Updated 6 months ago.

Status:
Closed
Priority:
Must have
Assignee:
-
Category:
Pagetree
Target version:
Start date:
2014-06-06
Due date:
% Done:

100%

TYPO3 Version:
6.2
PHP Version:
Tags:
Complexity:
Is Regression:
No
Sprint Focus:

Description

When creating a new page via drag'n'drop in the pagetree the configured TCAdefaults settings won't be applied to the newly created page.

For example tested with:

TCAdefaults.pages {
    # set page to visible
    hidden = 0

    # Hide page if no translation for current language exists
    l18n_cfg = 2
}

TYPO3 6.2.3


Related issues

Related to TYPO3 Core - Bug #62257: TCAdefaults are not respected when creating a page via drag'n'drop Closed 2014-10-15
Related to TYPO3 Core - Bug #46316: TCAdefaults in User tsconfig not working page created via pagetree Closed 2013-03-15
Related to TYPO3 Core - Bug #82548: TCAdefaults not work on 2 positions New 2017-09-24
Duplicated by TYPO3 Core - Bug #87089: TYPO3 Pagetree: New pages must respect TCAdefaults.pages.hidden = 0 and other properties Closed 2018-12-06
Duplicated by TYPO3 Core - Bug #87860: TCAdefaults does not work for pages with drag & drop Closed 2019-03-07

Associated revisions

Revision 49cfdfe8 (diff)
Added by Guido Schmechel 8 months ago

[BUGFIX] Use TSConfig defaults for DataHandler

Now the DataHandler observes the default values set in TsConfig. Example:

TCAdefaults.pages { # set page to visible
hidden = 0
}

Resolves: #59383
Releases: master, 9.5
Change-Id: I51e5d07e4e9a9457135bb9af88868cd52af373d7
Reviewed-on: https://review.typo3.org/c/58453
Tested-by: TYPO3com <>
Tested-by: Benni Mack <>
Tested-by: Markus Klein <>
Reviewed-by: Benni Mack <>
Reviewed-by: Markus Klein <>

Revision 9b0a5e94 (diff)
Added by Guido Schmechel 8 months ago

[BUGFIX] Use TSConfig defaults for DataHandler

Now the DataHandler observes the default values set in TsConfig. Example:

TCAdefaults.pages { # set page to visible
hidden = 0
}

Resolves: #59383
Releases: master, 9.5
Change-Id: I51e5d07e4e9a9457135bb9af88868cd52af373d7
Reviewed-on: https://review.typo3.org/c/59918
Tested-by: TYPO3com <>
Tested-by: Markus Klein <>
Reviewed-by: Markus Klein <>

History

#1 Updated by J. no-lastname-given over 4 years ago

I can confirm this bug in TYPO3 6.2.9 :(

You can set your TCAdefaults in pageTS. There it works, but bugfix would be great!

#2 Updated by Riccardo De Contardi about 4 years ago

Still valid for both 6.2.15 and 7.5-dev (latest master).

As stated in #46316, the bug only affects pages created with drag & drop from pagetree; it works if you use, for example, the list-view. And it works using PAGE TSConfig.

#3 Updated by Riccardo De Contardi about 4 years ago

  • Target version set to 7.5

#4 Updated by Benni Mack about 4 years ago

  • Target version changed from 7.5 to 7 LTS

#5 Updated by Mathias Schreiber about 4 years ago

  • Target version changed from 7 LTS to 8 LTS

#6 Updated by Riccardo De Contardi over 3 years ago

  • Category set to TypoScript

#7 Updated by Salvatore Eckel about 3 years ago

I confirm this bug for 6.2.26, 7.6.9 and 7.6.10.

Is anyone working on it? o.O

#8 Updated by Benni Mack over 2 years ago

  • Target version changed from 8 LTS to next-patchlevel

#9 Updated by Georg Tiefenbrunn over 2 years ago

Still present in version 8.7.1.

#10 Updated by Ruud Silvrants over 2 years ago

Still confirms the bug on 8.7.4

#11 Updated by Tymoteusz Motylewski over 1 year ago

  • Category changed from TypoScript to Pagetree

#12 Updated by Gerrit Code Review about 1 year ago

  • Status changed from New to Under Review

Patch set 1 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/58453

#13 Updated by Jürg Blaser about 1 year ago

Patch set 1 works for me. (TYPO3 8.7.19)

#14 Updated by Markus Klein about 1 year ago

@Blaser
Please use the Reply button at review.typo3.org for the patch linked above to vote and comment on the patch. Thanks.
(Login with your normal TYPO3 account)

#15 Updated by Riccardo De Contardi 12 months ago

  • Related to Bug #82548: TCAdefaults not work on 2 positions added

#16 Updated by Soren Malling 12 months ago

My current findings

Found first issue. Inside `fillInFieldArray` of the DataHandler class the incomingFieldArray is merged with the fieldArray (the second containing data touched by TCAdefaults). Chaning the order of the two arrays from
`ArrayUtility::mergeRecursiveWithOverrule($checkValueRecord, $incomingFieldArray);`
to
`ArrayUtility::mergeRecursiveWithOverrule($incomingFieldArray, $checkValueRecord);`

gives the correct values

#17 Updated by Josef Glatz 12 months ago

  • Duplicated by Bug #87089: TYPO3 Pagetree: New pages must respect TCAdefaults.pages.hidden = 0 and other properties added

#18 Updated by Gerrit Code Review 11 months ago

Patch set 2 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/58453

#19 Updated by Josef Glatz 11 months ago

Should we update the desired TYPO3 version to 9 in this issue?

#20 Updated by Gerrit Code Review 9 months ago

Patch set 3 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/c/Packages/TYPO3.CMS/+/58453

#21 Updated by Gerrit Code Review 9 months ago

Patch set 4 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/c/Packages/TYPO3.CMS/+/58453

#22 Updated by Benni Mack 8 months ago

  • Duplicated by Bug #87860: TCAdefaults does not work for pages with drag & drop added

#23 Updated by Gerrit Code Review 8 months ago

Patch set 1 for branch 9.5 of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/c/Packages/TYPO3.CMS/+/59918

#24 Updated by Guido Schmechel 8 months ago

  • Status changed from Under Review to Resolved
  • % Done changed from 0 to 100

#25 Updated by Benni Mack 6 months ago

  • Status changed from Resolved to Closed

Also available in: Atom PDF