Bug #62284

FormEngine does not trim subparts of each field in showitem

Added by Nils Blattner over 6 years ago. Updated about 5 years ago.

Status:
Closed
Priority:
Won't have this time
Assignee:
-
Category:
Backend API
Target version:
-
Start date:
2014-10-16
Due date:
% Done:

0%

Estimated time:
TYPO3 Version:
6.2
PHP Version:
Tags:
Complexity:
Is Regression:
No
Sprint Focus:

Description

Hi there

If you accidently use a space before an alternate label within showitems, the label is not interpreted as a LLL-label, but used literally instead. This impacts other parts of showitem aswell.

$GLOBALS['TCA']['tt_content']['types']['myext']['showitem'] = '
    CType;;4;button;1-1-1, header; LLL:EXT:myext/Resources/Private/Language/locallang_db.xlf:myext.header
';

Notice the space just before "LLL:..."

It can be solved by using trimExplode instead of explode (as shown in the attached patch).
From the possible other values incapsulated in these strings, I do not see any conflicts.

Cheers Nils


Files

20141016-formengine.diff (782 Bytes) 20141016-formengine.diff Nils Blattner, 2014-10-16 14:59
20141016-formengine.txt (776 Bytes) 20141016-formengine.txt Nils Blattner, 2014-10-16 16:41
#1

Updated by Tim Lochm├╝ller over 6 years ago

Note: The third param should not be TRUE, because it destroy such a configuration (your example): CType;;4;button;1-1-1

#2

Updated by Nils Blattner over 6 years ago

Absolutely, I made the patch in a hurry :)

=> The updated patch is without the "remove empty items"

#3

Updated by Mathias Schreiber about 5 years ago

  • Target version deleted (next-patchlevel)
#4

Updated by Georg Ringer about 5 years ago

  • Status changed from New to Closed
  • Priority changed from Must have to Won't have this time

Thanks for reporting this patch. even though this is absolutly valid, we don't want to spend too much time anymore with fixing the "old" formengine. the issue has been solved in 7 LTS as the whole formengine has been rewritten.

as you say yourself, there are other places as well which could be improved.

Also available in: Atom PDF