Bug #62487

beforeImg and name attribut

Added by Harald Dolderer over 5 years ago. Updated over 1 year ago.

Status:
Closed
Priority:
Should have
Assignee:
-
Category:
Frontend
Target version:
Start date:
2014-10-27
Due date:
% Done:

100%

TYPO3 Version:
6.2
PHP Version:
5.4
Tags:
Complexity:
Is Regression:
No
Sprint Focus:

Description

Hi,

beforeImg delivers deprecated name attribut instead of id for html5 doctype
<img class="bullet" width="26" height="11" alt="" name="img552_d3d6_0before" src="....

For border attribut you have config.disableImgBorderAttr to fix the problem.
Nothing found to fix the problem with name attribut.

Thank you for your help.

Harald

Associated revisions

Revision ac8471ce (diff)
Added by Benni Mack over 4 years ago

[BUGFIX] Use "id" attribute for HMENU images in HTML5

When setting no config.doktype=html5, then the TYPO3
Frontend renders everything as HTML5, except for
the "name" attribute for before/after logic of HMENUs,
which should use "id" attributes.

The "default" option needs to be taken into account
in order to use "id" instead of "name".

Resolves: #62487
Releases: master
Change-Id: If4cccffd499de4c81b862fa2a2e0fb194ac3bcec
Reviewed-on: https://review.typo3.org/45141
Reviewed-by: Wouter Wolters <>
Reviewed-by: Georg Ringer <>
Tested-by: Georg Ringer <>
Reviewed-by: Daniel Goerz <>
Tested-by: Daniel Goerz <>
Reviewed-by: Jigal van Hemert <>
Tested-by: Jigal van Hemert <>

History

#1 Updated by Riccardo De Contardi about 5 years ago

It is still present in TYPO3 6.2.12

steps to reproduce:

page.5 = HMENU
page.5.1 = TMENU
page.5.1.NO.allWrap = <li>|</li>
page.5.wrap =<ul>|</ul>

page.5.1.NO.beforeImg = fileadmin/Images/ducks-639069_640.jpg
page.5.1.NO.beforeImg.width=150
page.10 < styles.content.get

#2 Updated by Riccardo De Contardi almost 5 years ago

still present also on 7.4-dev (latest master)

#3 Updated by Riccardo De Contardi over 4 years ago

  • Target version set to Candidate for patchlevel

Still present on 7.6.1-dev (latest master)

#4 Updated by Benni Mack over 4 years ago

  • Target version deleted (Candidate for patchlevel)

If you set
config.doctype = html5
then all your problems are solved. However, we add a small change for convenience in CMS7.6.1 for that.

#5 Updated by Gerrit Code Review over 4 years ago

  • Status changed from New to Under Review

Patch set 1 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/45141

#6 Updated by Benni Mack over 4 years ago

  • Target version set to next-patchlevel

#7 Updated by Benni Mack over 4 years ago

  • Status changed from Under Review to Resolved
  • % Done changed from 0 to 100

#8 Updated by Oliver Hader over 2 years ago

  • Category changed from 1050 to Frontend

#9 Updated by Benni Mack over 1 year ago

  • Status changed from Resolved to Closed

Also available in: Atom PDF