Task #62595

Deprecate SU change-to mode

Added by Felix Kopp over 4 years ago. Updated 10 months ago.

Status:
Closed
Priority:
Could have
Assignee:
-
Category:
-
Target version:
-
Start date:
2014-11-01
Due date:
% Done:

100%

TYPO3 Version:
7
PHP Version:
Tags:
Complexity:
Sprint Focus:

Description

When admins take over user sessions in backend there are two mode: change-to and switch-back.

I see no need to change-to / take over without switch-back.
Only additional feature is a potential second click on "Logout" after switch-back to previous user - in order to logout completely.

Remove the change-to option and allow switch-back only

Associated revisions

Revision d995e87b (diff)
Added by Andreas Fernandez over 4 years ago

[!!!][TASK] Remove SU mode "change to" in EXT:beuser

This patch removes the ability to switch to a user permanently.
The user now always gets an "exit" button offered to switch back.

Resolves: #62595
Releases: master
Change-Id: I08925c5249aca30225016ffb047be09b5f48b338
Reviewed-on: http://review.typo3.org/33688
Reviewed-by: Markus Klein <>
Tested-by: Markus Klein <>
Reviewed-by: Anja Leichsenring <>
Tested-by: Anja Leichsenring <>

History

#1 Updated by Helmut Hummel over 4 years ago

Felix Kopp wrote:

Remove the change-to option and allow switch-back only

any reasons for that?

#2 Updated by Andreas Fernandez over 4 years ago

I'm not Felix, but it's imo an improvement in UX. You can easily get confused by both buttons.

Besided that, I never had the case that I su'd and never wanted to go back to the original session.

#3 Updated by Gerrit Code Review over 4 years ago

  • Status changed from New to Under Review

Patch set 1 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at http://review.typo3.org/33688

#4 Updated by Gerrit Code Review over 4 years ago

Patch set 2 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at http://review.typo3.org/33688

#5 Updated by Gerrit Code Review over 4 years ago

Patch set 3 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at http://review.typo3.org/33688

#6 Updated by Helmut Hummel over 4 years ago

Andreas Fernandez wrote:

I'm not Felix, but it's imo an improvement in UX. You can easily get confused by both buttons.

Yeah, but maybe improve the UI there then, hide it by default or whatever.

Besided that, I never had the case that I su'd and never wanted to go back to the original session.

This does not mean nobody had a usecase for this. I use "switch back" 99% of the time, but the 1% of the time the other option comes in handy

Anyway if Felix thinks removal is a must have, well then I will live with it …

#7 Updated by Gerrit Code Review over 4 years ago

Patch set 4 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at http://review.typo3.org/33688

#8 Updated by Gerrit Code Review over 4 years ago

Patch set 5 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at http://review.typo3.org/33688

#9 Updated by Felix Kopp over 4 years ago

  • Tracker changed from Bug to Task
  • Priority changed from Should have to Could have

Hey you! Thank you for the discussion and questions - this is not fixed yet, hoping for feedback and discussion.

User guidance in backend user module with two options is complicated. These two available options have never been distinguished enough (red/blue, "change-to"/"switch-back") - I always had to wait for the help window. I see no good solution to explain two options better; we should focus on one, on the better solution. When reducing the complexity one option needs to be removed.

The only difference after switching to a user with switch-to or switch-back is the layout is the bold red notice in the topbar - that should be changed also in my opinion afterwards. I am convinced that it is easier to remove final-switch-to, therefore unify the topbar after a switch and also also ease the complexity of backend user administration listing.

Pro:
+ Easier user interface (for newbies and regular users)
+ Expected behavior for logout after switch
+ Unified topbar after switch

Contra:
+ No possibility to switch from admin to "normal" user and leave the computer for another un-privileged user (<5% of use-cases)

In come to the conclusion that one option needs to be removed and that option should be switch-to.
Please feedback and help me understand the possible contras :) Thanks!

#10 Updated by Helmut Hummel over 4 years ago

Felix Kopp wrote:

User guidance in backend user module with two options is complicated. These two available options have never been distinguished enough (red/blue, "change-to"/"switch-back") - I always had to wait for the help window.

I agree.

I see no good solution to explain two options better;

Well, it shouldn't be too hard to just use a different icon, should it?

we should focus on one, on the better solution.
When reducing the complexity one option needs to be removed.

That is of course the easiest way to resolve this.

The only difference after switching to a user with switch-to or switch-back is the layout is the bold red notice in the topbar - that should be changed also in my opinion afterwards.

Changed in what way? It still must be visible, that I'm currently acting as a different user.

Contra:
+ No possibility to switch from admin to "normal" user and leave the computer for another un-privileged user (<5% of use-cases)

In come to the conclusion that one option needs to be removed and that option should be switch-to.
Please feedback and help me understand the possible contras :) Thanks!

I agree that there are very few use cases for the "switch to" and since you have more of a global picture of the result, I trust you in that decision.

Go ahead!

#11 Updated by Gerrit Code Review over 4 years ago

Patch set 6 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at http://review.typo3.org/33688

#12 Updated by Gerrit Code Review over 4 years ago

Patch set 7 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at http://review.typo3.org/33688

#13 Updated by Gerrit Code Review over 4 years ago

Patch set 8 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at http://review.typo3.org/33688

#14 Updated by Andreas Fernandez over 4 years ago

  • Status changed from Under Review to Resolved
  • % Done changed from 0 to 100

#15 Updated by Benni Mack 10 months ago

  • Status changed from Resolved to Closed

Also available in: Atom PDF