Bug #62682

Epic #61834: Create future proof Content Element with strong default

Task #61836: Reorganize Content Element properties within backend Extension

Task #61842: Refactor CSS-Styled-Content + Content Elements

Separate core and css_styled_content

Added by Patrick Broens about 5 years ago. Updated almost 4 years ago.

Status:
Closed
Priority:
Must have
Category:
Content Rendering
Target version:
Start date:
2014-11-04
Due date:
% Done:

0%

TYPO3 Version:
7
PHP Version:
Tags:
Complexity:
medium
Is Regression:
No
Sprint Focus:

Description

Make it possible to replace css_styled_content with another extension providing content elements without cluttering database and unused definitions and methods.

Keep only the necessary basic properties for content elements:
  • Authoring (user, tstamp, time)
  • Hierarchy (position, sorting, parent page)
  • Visibility (frontend user access, access time)
  • Channel (language, workspace)
Tasks
  • Move tt_content table definition to css_styled_content, except for fields mentioned above.
  • Move relevant TCA to css_styled_content. Keep the basic properties in “frontend”.
  • Move language labels, used in TCA, to css_styled_content.
  • Move user functions, used in TCA, to css_styled_content.
  • Move images, used in TCA, to css_styled_content.
  • Move the content preview for content elements in tx_cms_layout::tt_content_drawItem to css_styled_content

Related issues

Related to TYPO3 Core - Task #65922: Move unused tt_content TCA fields and the arrangement to css_styled_content or compatibility6 Closed 2015-03-23

History

#1 Updated by Mathias Schreiber almost 5 years ago

  • Target version changed from 7.0 to 7.1 (Cleanup)

#2 Updated by Mathias Schreiber almost 5 years ago

  • Target version changed from 7.1 (Cleanup) to 7.2 (Frontend)

#3 Updated by Mathias Schreiber over 4 years ago

  • Sprint Focus set to On Location Sprint

#4 Updated by Patrick Broens over 4 years ago

  • Status changed from New to Closed

Closed, since this work is done in #65922

#5 Updated by Anja Leichsenring almost 4 years ago

  • Sprint Focus deleted (On Location Sprint)

Also available in: Atom PDF