Bug #62695

RTE keeps inserting empty P tag before ULs on first save

Added by Urs Braem almost 7 years ago. Updated about 3 years ago.

Status:
Closed
Priority:
Should have
Category:
RTE (rtehtmlarea + ckeditor)
Target version:
Start date:
2014-11-04
Due date:
% Done:

0%

Estimated time:
TYPO3 Version:
6.2
PHP Version:
Tags:
Complexity:
Is Regression:
No
Sprint Focus:

Description

I have this in all my TYPO3 installations from 4.5 up to 6.2: when converting existing text into an UL and saving it, above the UL, an empty P tag is being added.

<p>&nbsp;</p>

I've made a video of it (on purpose, I used a public demo version): http://www.ursbraem.ch/temp/rte-ul.mov - it's a 6.0 installation, but the version really doesn't matter.


Related issues

Related to TYPO3 Core - Bug #62559: RTE wraps p tags around ul in chrome and operaClosedStanislas Rolland2014-10-30

Actions
Is duplicate of TYPO3 Core - Bug #59559: White space before list in RTE after savingClosedStanislas Rolland2014-06-13

Actions
#1

Updated by Stanislas Rolland almost 7 years ago

Is this in Chrome? Opera?

#2

Updated by Urs Braem almost 7 years ago

That's in Chrome on OS X, since quite a while.

I hadn't thought of posting it here, as I thought it might be a configuration issue on my part (see http://stackoverflow.com/questions/18440843/how-to-keep-typo3s-rte-from-adding-an-empty-line-before-uls)

I see, with firefox, this behaviour doesn't show up.

#3

Updated by Stanislas Rolland almost 7 years ago

  • Status changed from New to Resolved
  • Assignee set to Stanislas Rolland
  • Target version set to next-patchlevel

@Urs: This is a duplicate of #59559.

It was recently fixed in git by this change: https://review.typo3.org/#/c/33773/ which follows this other change https://review.typo3.org/#/c/33655/

This is working around Chrome and Opera bug. Since this is a WebKit bug, on OS X, it might be worthwhile testing it in Safari.

#4

Updated by Urs Braem almost 7 years ago

Awesome, thanks!

#5

Updated by Benni Mack about 3 years ago

  • Status changed from Resolved to Closed

Also available in: Atom PDF