Bug #59559

White space before list in RTE after saving

Added by Wouter Beeftink about 7 years ago. Updated over 2 years ago.

Status:
Closed
Priority:
Should have
Category:
RTE (rtehtmlarea + ckeditor)
Target version:
-
Start date:
2014-06-13
Due date:
% Done:

100%

Estimated time:
TYPO3 Version:
6.2
PHP Version:
Tags:
Complexity:
Is Regression:
No
Sprint Focus:

Description

When I insert a list in the RTE and save the page, an empty paragraph is inserted before the list. Obviously, that shouldn't happen.
When I remove the empty paragraph and hit save again, the paragraph doesn't reappear.

To reproduce:
  • Create a content element (text will do).
  • Add a few paragraphs in the RTE.
  • Add a list in between the paragraphs with one or more item.
  • Hit save.
  • Voila, an empty paragraph should be inserted above the list.

I can reproduce this in TYPO3 6.1.7 and 6.2.2.


Files


Related issues

Related to TYPO3 Core - Bug #62559: RTE wraps p tags around ul in chrome and operaClosedStanislas Rolland2014-10-30

Actions
Has duplicate TYPO3 Core - Bug #62695: RTE keeps inserting empty P tag before ULs on first saveClosedStanislas Rolland2014-11-04

Actions
#1

Updated by Stanislas Rolland over 6 years ago

  • Status changed from New to Accepted
  • Assignee set to Stanislas Rolland
#2

Updated by Stanislas Rolland over 6 years ago

  • Status changed from Accepted to Needs Feedback

Strangely, I thought I could reproduce this. But I just tried again with master and could not.

Are you able to reproduce this with TYPO3 CMS 6.2.6? In what version of which browser?

#3

Updated by Stanislas Rolland over 6 years ago

This is in Chrome, right?

#4

Updated by Stanislas Rolland over 6 years ago

I think that this is due to the problem reported in #62559.

And I think that the change that is attached to that issue does not resolve it in all cases.

#5

Updated by Gerrit Code Review over 6 years ago

  • Status changed from Needs Feedback to Under Review

Patch set 1 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at http://review.typo3.org/33772

#6

Updated by Gerrit Code Review over 6 years ago

Patch set 2 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at http://review.typo3.org/33772

#7

Updated by Stanislas Rolland over 6 years ago

  • Status changed from Under Review to Resolved
  • % Done changed from 0 to 100
#8

Updated by Gerrit Code Review over 6 years ago

  • Status changed from Resolved to Under Review

Patch set 1 for branch TYPO3_6-2 of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at http://review.typo3.org/33773

#9

Updated by Gerrit Code Review over 6 years ago

Patch set 2 for branch TYPO3_6-2 of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at http://review.typo3.org/33773

#10

Updated by Stanislas Rolland over 6 years ago

  • Status changed from Under Review to Resolved
#11

Updated by Benni Mack over 2 years ago

  • Status changed from Resolved to Closed

Also available in: Atom PDF