Bug #62794

Deprecate old mail related methods in GeneralUtility

Added by Christian Kuhn almost 6 years ago. Updated about 2 years ago.

Status:
Closed
Priority:
Should have
Assignee:
-
Category:
-
Target version:
-
Start date:
2014-11-09
Due date:
% Done:

100%

TYPO3 Version:
7
PHP Version:
Tags:
Complexity:
Is Regression:
No
Sprint Focus:

Related issues

Related to TYPO3 Core - Task #62793: Remove last bits of config.notification_* Closed 2014-11-09
Related to TYPO3 Core - Task #62782: "No RDCT-Workaround" in fe_login is now unused Closed 2014-11-08
Related to TYPO3 Core - Bug #62831: Revoke deprecation of makeRedirectUrl() Closed 2014-11-10

Associated revisions

Revision 146142c5 (diff)
Added by Christian Kuhn almost 6 years ago

[TASK] Deprecate old mail related methods in GeneralUtility

Some mail related methods in GeneralUtility are obsolete and
unused in core and can be deprecated now.

Change-Id: Ie2fe3a841a1f83fc23d11381c083b65fb10b32eb
Resolves: #62794
Releases: master
Reviewed-on: http://review.typo3.org/33920
Reviewed-by: Benjamin Mack <>
Tested-by: Benjamin Mack <>
Reviewed-by: Wouter Wolters <>
Tested-by: Wouter Wolters <>

Revision 5482f3ba (diff)
Added by Christian Kuhn almost 6 years ago

[TASK] Revoke deprecation of makeRedirectUrl()

Method GeneralUtility::makeRedirectUrl() was deprecated with #62794.
The patch intended to deprecate some old mail handling methods, but
makeRedirectUrl() is the general URL shortening feature in the core
that should not be kicked.

Change-Id: Idda2f13b962feda3b8e195e2c331b6d5e25f5498
Resolves: #62831
Related: #62794
Releases: master
Reviewed-on: http://review.typo3.org/33954
Reviewed-by: Stefan Froemken <>
Tested-by: Stefan Froemken <>
Reviewed-by: Alexander Opitz <>
Tested-by: Alexander Opitz <>
Reviewed-by: Wouter Wolters <>
Tested-by: Wouter Wolters <>

History

#1 Updated by Gerrit Code Review almost 6 years ago

  • Status changed from New to Under Review

Patch set 1 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at http://review.typo3.org/33920

#2 Updated by Christian Kuhn almost 6 years ago

  • Status changed from Under Review to Resolved
  • % Done changed from 0 to 100

#3 Updated by Benni Mack about 2 years ago

  • Status changed from Resolved to Closed

Also available in: Atom PDF