Bug #62930

RTE maxWidth for magic images

Added by Bernhard Kraft over 6 years ago. Updated over 2 years ago.

Status:
Closed
Priority:
Must have
Assignee:
-
Category:
RTE (rtehtmlarea + ckeditor)
Target version:
Start date:
2014-11-13
Due date:
% Done:

100%

Estimated time:
TYPO3 Version:
6.2
PHP Version:
5.3
Tags:
Complexity:
Is Regression:
No
Sprint Focus:

Description

The page TS-Config setting:

RTE.default.buttons.image.options.magic.maxWidth = 648

doesn't currently not work. The reason is burried in the change to use FAL instead of previous handling of magic images. In the backend the RTE pageTS config is retrieved in "backend/Classes/Form/Element/TextElement.php": https://git.typo3.org/Packages/TYPO3.CMS.git/blob/HEAD:/typo3/sysext/backend/Classes/Form/Element/TextElement.php#l86

The method "RTEsetup" in Backend utility retrieves the proper page TS config section:
https://git.typo3.org/Packages/TYPO3.CMS.git/blob/HEAD:/typo3/sysext/backend/Classes/Utility/BackendUtility.php#l3543

You see that it uses the section "RTE.default" while in the FAL new magic image just the page-TS-config "RTE" section is used:
https://git.typo3.org/Packages/TYPO3.CMS.git/blob/HEAD:/typo3/sysext/rtehtmlarea/Classes/Controller/ImageRenderingController.php#l126

I guess it would be sufficient to just directly use ".default" subsection. Maybe the ".FE" section should get overlaid but I assume the ".FE" section of RTEhtmlarea TS-Config is intended for FE editing.

#1

Updated by Bernhard Kraft over 6 years ago

The bug is also reported here (in German):
http://www.typo3.net/forum/thematik/zeige/thema/117185/

#2

Updated by Gerrit Code Review over 6 years ago

  • Status changed from New to Under Review

Patch set 1 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at http://review.typo3.org/34102

#3

Updated by Bernhard Kraft over 6 years ago

An easy fix until the issue is fixed in core:

RTE.buttons.image < RTE.default.buttons.image
#4

Updated by Gerrit Code Review over 6 years ago

Patch set 1 for branch TYPO3_6-2 of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at http://review.typo3.org/34294

#5

Updated by Anonymous over 6 years ago

  • Status changed from Under Review to Resolved
  • % Done changed from 0 to 100
#6

Updated by Benni Mack over 2 years ago

  • Status changed from Resolved to Closed

Also available in: Atom PDF