Bug #63045

Properly encode UTF8 file paths when migrating RTE file links

Added by Nils Blattner about 6 years ago. Updated about 5 years ago.

Status:
Closed
Priority:
Should have
Assignee:
-
Category:
Install Tool
Target version:
Start date:
2014-11-18
Due date:
% Done:

100%

Estimated time:
TYPO3 Version:
6.2
PHP Version:
5.3
Tags:
Complexity:
easy
Is Regression:
No
Sprint Focus:

Description

Hi there

The upgrade wizard for RTE file links does not properly encode UTF8 paths when searching for the <link> in the database resulting in "xxx/xxx.pdf not found in referenced element (uid: 123 of table tt_content in field bodytext). Reference index was probably out of date." messages.

The attached patch should take care of that.

Cheers Nils


Files

RteFileLinksUpdateWizard.php.diff (780 Bytes) RteFileLinksUpdateWizard.php.diff Nils Blattner, 2014-11-18 11:40
#1

Updated by Mathias Schreiber about 6 years ago

  • Target version changed from next-patchlevel to 7.4 (Backend)
#2

Updated by Susanne Moog over 5 years ago

  • Category changed from Install Tool to 1601
#3

Updated by Susanne Moog over 5 years ago

  • Target version changed from 7.4 (Backend) to 7.5
#4

Updated by Benni Mack over 5 years ago

  • Target version changed from 7.5 to 7 LTS
#5

Updated by Benni Mack about 5 years ago

  • Category changed from 1601 to Install Tool
  • Target version changed from 7 LTS to next-patchlevel
#6

Updated by Benni Mack about 5 years ago

  • Status changed from New to Closed

Already fixed in 6.2

Also available in: Atom PDF